buildworld error

Minnesota Slinky mnslinky at
Sat Nov 8 19:38:18 PST 2003

Hey people, I just had this problem.

Here's what worked for me:

rm -r /usr/obj
cd /usr/src
make world


Eric F Crist
AdTech Integrated Systems, Inc
(952) 403-9000

-----Original Message-----
From: owner-freebsd-questions at
[mailto:owner-freebsd-questions at] On Behalf Of Kent Stewart
Sent: Saturday, November 08, 2003 2:27 PM
To: Jason; freebsd-questions at
Subject: Re: buildworld error

On Saturday 08 November 2003 12:10 pm, Jason wrote:
>     Last night I updated all my source files to buildworld, but ran
> a problem.  I tried to build it 3 times, and each time it stops at the
> same spot.  If I retype the last commands show letter for letter they
> work.  It stops at something like $gzip -cn >
> I immediately enter this command after the error it does not work, but
> above it is a 3 line command for makeinfo.  If I renter this command
> then the gzip works.  If this just some small glitch in some config
> that has already been fixed?  If it has not been fixed, or no one
> what file show I look into to correct this myself?  I am running 5.1
> with my cvs tag set to current.  The error occurs about 38 minutes
> the build, so I would  be glad to try suggestions but I don't want to
> waste a day on this.
> Thanks,
> Jason

First rule of thumb is to re-cvsup src-all after you have waited awhile.
that doesn't work, include the error messages. 

If you are following -current, you should also be subscribed to the
lists that 
deal with problems, such as cvs-all, hackers, -current, and etc. You can
the problem being addressed and then fixed. 

This used to be part of the suggested requirements for following stable
they definitely apply to current.


Kent Stewart
Richland, WA

freebsd-questions at mailing list
To unsubscribe, send any mail to
"freebsd-questions-unsubscribe at"

More information about the freebsd-questions mailing list