XFree86 upgrade from 4.2.1 to 4.3.0, any keyboard press results in mode change

Edward Wei Edward.Wei at Dartmouth.EDU
Thu May 29 23:11:09 PDT 2003

Hi Brian,

It's been a long time.  I hope you've fixed the problem by now.
But if you haven't, and for the sake of others, I solved this problem

In XFree-4_libraries port:
make deinstall

make install

or 'portupgrade' or what you like.

Something obviously went wrong with the port.  reinstalling fixed the problem.
Note that you don't have to be as destructive as rm -rf   A simple deinstall would
be safer and less hassle.


-- You Wrote: ---
I upgraded a workstation today previously running Gnome 2.0,
FreeBSD-STABLE as of November or so (4.7 I think),
and XFree86-4 4.2.1, to Gnome 2.2, FreeBSD 4-STABLE as of today, and
XFree86-4.3.0.  I did a make world from source, but installed Gnome and
XFree86 as packages from the 4.8-RELEASE CD.

XFree86 starts up fine, Gnome 2.2 starts up, my Eterm shells start, it all
looks great... until I try and type, and then any key I press on the
keyboard results in an X resolution mode change.  Kind of annoying, and
I'd like to fix it.  I can't find anything unusual in

I'm still using the "keyboard" driver in my XF86Config file; I tried
changing that to "kbd" and it had no difference.  I'm about ready to rm
-rf /usr/X11R6 but I'd prefer to know exactly what's causing this.  Where
should I start looking?


More information about the freebsd-questions mailing list