Apache error

John DeStefano deesto at yahoo.com
Thu May 29 06:25:48 PDT 2003

I had some trouble getting Apache2 to run properly on my machine, so I uninstalled the port and started over with a new port installation.
It seemed to work fine "out of the box" with very few changes to the httpd.conf file.  I'm able to 'lynx http://localhost' with no trouble, and last I checked I was able to view the page from another browser on my local LAN using my external IP address after 'poking a hole' in my router firewall to allow traffic for port 80 through to the server.  However, I've run into a bit of a problem now: I haven't changed anything since yesterday, and I can't browse the site from an external computer (at work).
Also, I get the following, strange error when checking the status of the daemon:
# apachectl --status
(48)Address already in use: make_sock: could not bind to address [::]:80
no listening sockets available, shutting down
Unable to open logs
Despite all this, the server is still running (or running again?) and I can still 'lynx' to it when I ssh to my server, even from work; I just can't access it via the Web.
The server thread looks like it's okay, even though it's somehow now serving bothIP4 and IP6; last night it showed only 'tcp6' and I haven't changed any config settings:
# netstat -nat | grep 80
tcp46      0      0  *.80                   *.*                    LISTEN

Do I need to open a hole somewhere I haven't yet?
Also, I'll eventually need to change port 80 to another, unused port, as my ISP does not allow web hosting.  I once tried to fix this by changing the port number in two places in httpd.conf: 'Listen' and 'ServerName'.  This seemed to change the port of the thread, as 'netstat' showed the new port, but nothing else worked.  Where else must the port number be changed?

Do you Yahoo!?
Free online calendar with sync to Outlook(TM).

More information about the freebsd-questions mailing list