Boot problem: "ata0: resetting devices"

Rich Morin rdm at
Wed May 28 22:14:28 PDT 2003

I recently purchased a new motherboard (ECS EliteGroup Mainboard P4S5A/DX+;
AMI BIOS) and a matching CPU (Celeron, 478 pin, 2.1 GHz) from
I stuffed these into an old chassis, adding a 500 W power supply and a pair
of 512 MB DDR DIMMs.

After walking through the configuration (accepting "Optimal Settings" for
everything), I tried booting up the machine on an IDE drive that was loaded
with FreeBSD and had been used most recently with a 200 MHz Pentium II.

The boot sequence proceeded without problems for quite a while, checking
devices, etc.  Then, however, it halted with a pair of nastygrams:

   ad0: READ command timeout tag=0 serv=0 resetting
   ata0: resetting devices

I tried putting the ATA drive and the CDROM on separate cables, but that
didn't seem to help.  My suspicion is that the drive is too slow for the
ATA controller, but I don't see any way to compensate for this.  Help?

email: rdm at; phone: +1 650-873-7841    - my home page, resume, etc.   - The FreeBSD Browser, Meta Project, etc. - Prime Time Freeware's DOSSIER series     - Prime Time Freeware's Darwin Collection

More information about the freebsd-questions mailing list