Can't start X

Socketd db at
Wed May 28 09:20:19 PDT 2003

Hi all

Just got a new laptop and install FreeBSD 4.8-release (mini) on it. Next
I installed gnome2 and then Xfree86-server. I configured x with
xf86config and tried running x with "startx", but got this error:

could not open default font 'fixed'

I found out XFree86-FontServer wasn't installed, so I installed it,
rebooted but still no luck. 
What is wrong and did I even have to installed the FontServer?

Please cc to me as I am not on the list.


Error message:
lab# startx
Using authority file /root/.Xauthority
Writing authority file /root/.Xauthority
xauth: (argv):1:  bad display name "lab:0" in "list" command
Using authority file /root/.Xauthority
xauth: (stdin):1:  bad display name "lab:0" in "add" command

XFree86 Version 4.3.0
Release Date: 27 February 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: FreeBSD 4.8 i386 [ELF] 
Build Date: 28 May 2003
	Before reporting problems, check http://www.XFree86.Org/
	to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
         (++) from command line, (!!) notice, (II) informational,
         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Wed May 28 18:02:17 2003
(==) Using config file: "/etc/X11/XF86Config"

Fatal server error:
could not open default font 'fixed'

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to xfree86 at

X connection to :0.0 broken (explicit kill or server shutdown).
xauth: (argv):1:  bad display name "lab:0" in "remove" command

More information about the freebsd-questions mailing list