Spooky em INTEL PRO 1000 driver?

Christoffer Pio cp at cvt.dk
Tue May 27 02:15:19 PDT 2003


Don Bowman suggested to reduce or simply disable auto-negotiation
by setting if_em.h:#define WAIT_FOR_AUTO_NEG_DEFAULT 1
to 0 and forcing the correct settings with ifconfig 
(ifconfig em0 inet x.x.x.x netmask x.x.x.x media 100BaseTX mediaopt full-duplex).
I tried this but still experienced waiting over 1 minute when bringing up the nic.

However, problem disappeared when I hooked the nic into a Netgear
switch instead of the older 48 port Cisco Catalyst 2849 switch. It seems
the lag was caused by the switch-end trying to negotiate, even with the
nic having auto-negotiation disabled and forced settings.

Christoffer Pio

Scott_Koh/Bluewave.BLUEWAVE at bluewave.com wrote:
> Hi Christoffer,
> We did not encounter the problem you mentioned on all our x345 servers.
> All our servers are connected using the first nic - em0. No problem with
> syslogd timeout etc during boot up.
> We did encounter problem though, trying to unplumb em1 by ifconfig em1
> destroy.
> Checking in progress.
> Regards,
> SK
>                       "MFW"
>                       <mwilliams at 2goons        To:       Christoffer Pio <cp at cvt.dk>, <Scott_Koh/Bluewave.BLUEWAVE at bluewave.com>
>                       .net>                    cc:       <freebsd-isp at freebsd.org>, <freebsd-questions at freebsd.org>, "Erwin
>                                                 Lansing" <erwin at lansing.dk>, <owner-freebsd-questions at freebsd.org>
>                       05/27/2003 12:41         Subject:  Re: Spooky em INTEL PRO 1000 driver?
>                       AM
>                       Please respond to
>                       mwilliams
> Christoffer,
> I have a similar problem with another driver. I am assuming that you have
> the
> em driver compiled in your Kernel (I think its in GENERIC in 4.8). Here is
> what I did to combat the similar problem. Take the ifconfig_em(x) and
> defaultrouter out of the rc.conf. Make a simple if_up.sh script in
> /usr/local/etc/rc.d to bring up your interfaces and bring up your default
> route. I run a sleep command in mine for 5 seconds to give other services
> time
> to load before I bring up the interfaces. Syslog should come up regardless
> of
> network services, unless you are doing remote syslog. Either way, the above
> worked for me.
> If that doesn't work, check to make sure you have the em driver compiled in
> your Kernel. Sounds like its trying to kldload the em driver, therefore
> making
> your services not start in the process (no network activity). If it is
> loading
> the module at boot up, then make the above script, but load the module at
> the
> top. Its all the same.
> Just an idea. Not saying it the right thing to do, but its one that worked
> for
> me.
> Christoffer Pio <cp at cvt.dk> wrote:
> > Hello
> >
> > I am experiencing some spookynes with FreeBSD 4.8 on the IBM
> > x345 2U machine; the x345 comes with two on-board INTEL 100/1000 mb nics
> > which uses the em driver. However, whenever I "up" one of the nics,
> > there is a slight delay of a few seconds before the command
> > completes, also the nic is not operating in up state yet,
> > appr. 30 seconds passes before traffic actually can pass
> > in/out .. It happens regardless if there is a cable attached
> > to the nic. I find this rather spooky. Has anyone using the
> > em driver experienced this? Other than being spooky it
> > causes a problem with the box in question, since syslogd and
> > other daemons times out at boot-up.
> >
> > Please include my email in any replies.
> >
> > Thanks
> > Christoffer
> > <cp at cvt.dk>
> > _______________________________________________
> > freebsd-isp at freebsd.org mailing list
> > http://lists.freebsd.org/mailman/listinfo/freebsd-isp
> > To unsubscribe, send any mail to "freebsd-isp-unsubscribe at freebsd.org"
> >
> _________________________________________________________
> This mail sent using V-webmail - http://www.v-webmail.org

More information about the freebsd-questions mailing list