lan problem

Bill Moran wmoran at
Thu May 22 15:18:48 PDT 2003

pat bey wrote:
> # netstat -rn
> Internet:
> Destination            Gateway                     Flags          Ref    Use  Netif 
> default                          UGSc          2        1    sis0
>                          UH              0      382   lo0
> 192.168.0                link#1                        UC              4        0    sis0
>         00:09:5b:1b:89:0d        UHLW        1       241   lo0
>         link#1                          UHLW        0        5     sis0
>        ff:ff:ff:ff:ff:ff:ff:ff                 UHLWb      1       77    sis0
> I left out the expire part sense their was nothing under it.  
> I left out the Internet6 part cause when installing I configured it for ipv4.
> I don't know if I have ICMP enable on the router or not I have ports 20-2999 open on the router.  Strange thou the router says is the win xp box why is it in my my netstat.  I tried telneting to the router it won't let me

Do you see this eighty-foot line ^^^^^

Do you think you can learn to use the "enter" key? shows up in the list because the FreeBSD box heard it on the local
network and thus created an ephemeral route so it knows where to find it.  This
is A Good Thing.

Cany you ping from the FreeBSD box?  Can you ping FreeBSD from
the XP box?  If so, it sounds like your "router" is misconfigured.

> pat bey wrote:
>>Can anyone help me solve this problem??
>>I have two boxes win xp and FreeBSD 4.6 and a DLink 704P router which has built-in
>>nat and dhcp server. Here is a diagram of my setup.
> [code] -----------------------------
>>| dsl modem |
>>| router |
>>| |
> --------------------------------| |------------------------------
> | |
> ---------------------- ------------------ ------------------- | |Win XP box | | FBSD4.6 box |
> ---------------------- ------------------------- [/code]
>>I followed the online handbook to setup this box, everything is configured for dhcp.
>>Using the GENERIC kernel. I tried pinging & my nic
>>which had 0% packet loss. But when I try to ping the router I get a message of route
>>to host down. I have Bind running as a caching server . I updated the firmware for
>>a unix sys and I can't get out to the world from this box. The windows box have no
>>problem getting out to the world. On the router I have ports tcp,udp 20-2999 open
>>for both mac address. The router sees both MAC's but the FBSD box can't even access
>>the routers web page. I have another nic card should I install it and put the BSD
>>box in front of the router. Or can anyone help me solve this problem.
> Can you ping
> Can you ping the IP of the Win XP machine?
> Do you have ICMP packets blocked on the "router"?
> Are you pinging IP addys or names? (start with IPs, once that works, then try names)
> Can you post the output of 'netstat -rn'?
>># ifconfig
>>sis0: flags=8843 mtu 1500
>>inet netmask 0xffffff00 broadcast
>>ether 00:12:34:56:78
>>media: Ethernet autoselect (100baseTX )
>>status: active
>>lo0: flags=8049 mtu 16384
>>inet netmask 0xff000000
>># rc.conf
>>and the rest is just set to the default.
>>I had Redhat Linux 7.2 installed before and it work with no problem straight
>>out of the box. I been working on this for a 2 months with no luck. Can
>>anyone help me out. I chose the 4.6 version cause it was all that my local
>>comp had as far as BSD that came with a handbook.

Bill Moran
Potential Technologies

More information about the freebsd-questions mailing list