mysql/php/apache weirdness

Nils Vogels nivo+freebsd-questions at
Wed May 21 08:26:51 PDT 2003

On Wed, May 21, 2003 at 02:16:27AM -0500, sektie (s) wrote:
s> The mysql console client (ie: 'mysql' at command line) works just fine. 
s> php/mysql/apache have all been compiled from ports. I have tried everything I 
s> could possibly think of, including recompiling php. No dice. I've not really heard 
s> much about anyone else having this problem. I could go back to using 3.23.54 
s> and it would all work ok, but I'd really rather figure out what the problem is. The 
s> webpage that is having the issues (so you can see the problem firsthand) is 
s> Ugh. I hope someone here has an idea of 
s> what is going on, because I'm lost. 

I had the same problem with a somehow fscked-up compile of 3.23.54 .. whenever
I used a tcp/ip socket, my mysqld  would freak out on me and die. Whenever I
used a local socket (which is faster anyway :D) it would survive and work just

I rebuilt the binary into a static binary, to see if that made any difference
(make -DBUILD_STATIC=yes or something) and it solved the problem for me ..


More information about the freebsd-questions mailing list