Belkin F5U103 and ubsa driver

Steve Lin stevenclin at
Wed May 21 06:23:05 PDT 2003

Has anyone gotten the ubsa driver to work correctly with a Belkin F5U103
USB to RS232 adapter?

I was running 4.7-RELEASE and needed support for this device. I tried two

1)  I first tried upgrading to 5.0-RELEASE and compiling the kernel with:

device      ubsa
device      ucom

During bootup, I always saw the following messages and /dev/ucom0 was not
present after boot:

uhci0: <VIA 83C572 USB controller> port 0xd400-0xd41f irq 5 at device 17.2
on pci0
usb0: <VIA 83C572 USB controller> on uhci0
usb0: USB revision 1.0
uhub0: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
ubsa0: Belkin Components F5U103 Serial adapter, rev 1.10/2.04, addr 2
ubsa0: failed to set configuration: SHORT_XFER
device_probe_and_attach: ubsa0 attach returned 6
uhub0: port 1, set config at addr 2 failed
uhub0: device problem, disabling port 1

2)  Thinking that 5.0 might be a bit too leading edge for me, I wiped it
out and installed 4.8-RELEASE, which also has ubsa support.  Again put the
same kernel config changes in and this time the dmesg output looks fine;
all I see is this:

ubsa0: Belkin Components F5U103 Serial adapter, rev 1.10/2.04, addr 2

and after MAKEDEV'ing /dev/ucom0, I can actually open it.  HOWEVER,
nothing seems to happen.  When doing "cu -l /dev/ucom0", I'm not able to
communicate with any serial devices.

The lights on the Belkin indicate that at first, it is receiving
characters during my "cu" session (the green LED blinks) but after a
while, even that stops happening...


USB keyboard and mouse work okay.  And I've tried two different Belkin
adapters, both of which work under Windows, so I don't think it's a
hardware or BIOS configuration problem...

Any help would be GREATLY appreciated!  I desperately need to add a couple
more serial ports to my machine, and USB is really the only free port I

Steve Lin

More information about the freebsd-questions mailing list