shutdown -p now

Robert Storey y2kbug at
Wed May 21 05:23:44 PDT 2003

On Tue, 20 May 2003 20:46:43 -0500
"Jack L. Stone" <jackstone at> wrote:

> At 09:22 AM 5.21.2003 +0800, Robert Storey wrote:
> >Dear All,
> >
> >I'm trying to get my computer to shut down and turn the power off. I'm
> >aware of the command "shutdown -p now". It doesn't work for me, and
> >after
          ================  SNIP =============

> Don't know why your switch quit, but if your computer can manage the
> shutdown, you need these:
> In the kernel
> # device apm0 at nexus? flags 0x20 #Advanced Power Management

Dear Jack,

Thanks for the information. I went ahead and tried that, but when I tried
to configure the new custom kernel, I got this error message:

 root at sonic:/sys/i386/conf> /usr/sbin/config CUSTOM2
 config: CUSTOM2:156: devices with zero units are not likely to be correct

I decided to stop there rather than compile a possibly flakey kernel. Is
this error message anything to worry about, or am I doing something wrong?


> ...and in rc.conf
> # apm_enable="YES"
> You should see in the bootup (dmesg):
> apm0: <APM BIOS> on motherboard
> apm: found APM BIOS v1.2, connected at v1.2
> Hope it helps...
> Best regards,
> Jack L. Stone,
> Administrator
> SageOne Net
> jackstone at
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to
> "freebsd-questions-unsubscribe at"

More information about the freebsd-questions mailing list