mysql/php/apache weirdness

sektie sektie at
Tue May 20 23:16:50 PDT 2003

This is on a fbsd-5 'puter.  
When mysql 3.23.56 first came out in the ports tree, I used portupgrade to install it 
the very next day. Previous to that, I believe I was running mysql 3.23.54. I was 
running a website that uses very simple php code that interfaces with my mysql 
db, but it just started dying with 3.23.56. dying bad. Any time the php script tried 
to do _anything_ with the db (like, um, opening it?), i'd get this in the mysql error 
/usr/local/libexec/mysqld: ready for connections 
030329 19:52:31  mysqld restarted 
Cannot initialize InnoDB as 'innodb_data_file_path' is not set. 
If you do not want to use transactional InnoDB tables, add a line 
to the [mysqld] section of init parameters in your my.cnf 
or my.ini. If you want to use InnoDB tables, add to the [mysqld] 
section, for example, 
innodb_data_file_path = ibdata1:10M:autoextend 
But to get good performance you should adjust for your hardware 
the InnoDB startup options listed in section 2 at 
/usr/local/libexec/mysqld: ready for connections 
mysqld got signal This could be because you hit a bug. It is also possible that this 
or one of the libraries it was linked against is corrupt, improperly built, 
or misconfigured. This error can also be caused by malfunctioning hardware. 
We will try our best to scrape up some info that will hopefully help diagnose 
the problem, but since we have already crashed, something is definitely wrong 
and this may fail 
It is possible that mysqld could use up to 
key_buffer_size + (record_buffer + sort_buffer)*max_connections = 225791 K 
bytes of memory 
Hope that's ok, if not, decrease some variables in the equation 
The line that is causing all of this is: 
$db = mysql_connect("", "<username>","<password>") 
The mysql console client (ie: 'mysql' at command line) works just fine. 
php/mysql/apache have all been compiled from ports. I have tried everything I 
could possibly think of, including recompiling php. No dice. I've not really heard 
much about anyone else having this problem. I could go back to using 3.23.54 
and it would all work ok, but I'd really rather figure out what the problem is. The 
webpage that is having the issues (so you can see the problem firsthand) is Ugh. I hope someone here has an idea of 
what is going on, because I'm lost. 

More information about the freebsd-questions mailing list