About my problem

Teilhard Knight teilhk at Phreaker.net
Sat May 17 04:33:23 PDT 2003

On Wed, 2003-05-14 at 13:15, Matthew Seaman wrote:
> On Wed, May 14, 2003 at 11:05:50AM -0500, Teilhard Knight wrote:
> > Thank you, Matthew. I tried as you said, but I couldn't pass the first
> > step. I got the message: "cannot boot /kernel, kernel module already
> > loaded" Of course I tried "kernel" and other variants. If I typed
> > "unload" and then what you said, I ended up with the prompt for the
> > manual file system feed.
> Oops. Yes.  Sorry.  By the time you get to the loader prompt, the
> kernel has already been loaded.  You can just type:
>     boot -s 
> at that point.  Doing the unload then the full boot path thing is a
> long winded way of achieving the same effect.
> >                          But I could boot with a kernel back up I had
> > and I made the modifications to the fstab file with a regular editor. My
> > doubt was that the slices still were called ads2s2a, etc., but I
> > supposed that that could change with the changes in the fstab file. I
> > knew that if something went wrong, I could not boot anymore from my back
> > up kernel, but I would get to the same request for a hand-input
> > filesystem and I would only had to specify ad2s2a. Well, nothing worked.
> > I cannot boot now. It seems to me that the utility to specify by hand
> > the filesystem either doesn't work or that I have a deeper problem here.
> > I am now tempted to get done with 4.8 and try 5.0. What do you think?
> Hmmm... Clarify for me: which disk is it exactly that your FreeBSD
> installation is on?  ie. what does 'lsdev' return at the boot loader
> prompt?  If you're using a GENERIC kernel, or your kernel config contains
>     options  ATA_STATIC_ID
> then the disks are numbered like this:
>     ad0      Master on the 1st IDE bus
>     ad1      Slave  on the 1st IDE bus
>     ad2      Master on the 2nd IDE bus
>     ad3      Slave  on the 2nd IDE bus
> If you haven't got that option in your kernel, then the disks present
> in your system just get numbered in order.

You confirm what I figured out was the cause of it all after getting rid
of 4.8 and going into 5.0. I removed that option, I remember. I now have
another problem with 5.0. If I cannot solve it, I can always go back to
4.8, where I know now at least I won't get into the same problem again.
I am a very impatient bloke, if I had just waited for your feedback ....

Teilhard Knight
The Extraterrestrial

Who ate my sandwich? 

More information about the freebsd-questions mailing list