4.8 startx can't open /dev/io (or /dev/mem)

peter.billam at pjb.com.au peter.billam at pjb.com.au
Fri May 16 13:22:27 PDT 2003

Greetings. I've just got FreeBSD 4.8 installed, and startx gives me:

  XFree86 Version 4.3.0
  (WW) checkDevMem: failed to open /dev/mem (Operation not permitted)
  Fatal Server Error: xf86EnableIO: failed to open /dev/io for extended I/O

I'm not actually even using extended I/O; in /etc/X11/XF86Config
there is an "Other input device sections" but it's all commented out.

The problem persists if I'm root, or if I
  chmod 666 /dev/io
or if I
  cd /dev ; rm io ; sh MAKEDEV io
so it's not permission-related.

So then I tried to get XFree86.0.log onto a floppy to transfer
it to my working machine, and was surprised to find that
  cd /var/log ; tar cvf /dev/fd0 XFree86.0.log
similarly gives
  tar: /dev/fd0; Cannot open: Operation not permitted
(even though the floppy was _not_ write-protected :-)
and yet _reading_ from the floppy (tar tvf /dev/fd0) works fine.

So maybe it's not an X thing, but a broad-scale mess-up of /dev ?
I tried repartioning and reinstalling, but that changed nothing :-(

Surely other 4.8ers must have met this ? Any help gratefully received ...

Regards,  Peter Billam

Peter Billam  www.pjb.com.au peter.billam at pjb.com.au  (03) 6278 9410
GPO Box 669, Hobart TAS 7001, Australia.  Original compositions made
to be played, and arrangements of Bach, Schubert, Brahms...  Special
Offer ! Everything Free ! And, soon . . . November at the Carousel !

More information about the freebsd-questions mailing list