Vinum & Firewire?

Drew Tomlinson drew at
Fri May 16 06:29:29 PDT 2003

----- Original Message ----- 
From: "Greg 'groggy' Lehey" <grog at>
To: "Drew Tomlinson" <drew at>
Cc: "FreeBSD Questions" <freebsd-questions at>
Sent: Thursday, May 15, 2003 6:49 PM

On Thursday, 15 May 2003 at 15:18:03 -0700, Drew Tomlinson wrote:
>> I have created a large vinum volume consisting of one concatenated plex.
>> The volume uses 3 drives.  Two of the three are IDE drives mounted in the
>> system case and attached to the IDE controller on the motherboard.  A
>> made from these two drives functioned flawlessly for over a year.
>> Then the volume finally filled so I added another IDE drive.  However I
>> not have room in the system case so I put the drive in a firewire
>> and added a firewire card to the system.  Everything seems to work fine
>> the system is up and running.
>> The problem is that upon boot, the firewire drive is not available to
>> as indicated in this 'list' command:
>> D ftp2                  State: referenced       Device  Avail: 0/0 MB
>> Which, of course, leads to a 'corrupt' plex and 'crashed' subdisk:
>> P ftp.p0              C State: corrupt  Subdisks:     3 Size:        223
>> S ftp.p0.s2             State: crashed  PO:      149 GB Size:         74
>> I suspect the cause is that the firewire drive is not ready at the time
>> vinum starts.
>That's one possibility.
>> Can anyone confirm or deny this?
>I haven't used firewire at all, so I can't say.  But it would seem
>that if you stop Vinum and start it when the firewire drive is up, you
>should be able to confirm this yourself by restarting and seeing what

I tried this.  Because my /usr is also a vinum volume, I rebooted with
'boot -s' then issued a start command.  Same error with ftp2.

Next, I used the create command to redefine the drive, stopped and started
the plex and subdisks, and then mounted the volume.  Wrote some data to it
to test. Volume was working.

I rebooted again with 'boot -s' but the problem persisted.  ftp2 remains in
a 'referenced 0/0MB' state.

>> Is there a way to add a delay in the boot process to allow the
>> firewire drive extra time?
>I'm sure there is, but first we should determine whether that's really
>the problem.

Agreed.  Thanks for keeping me focused.

>> Should I not use vinum with firewire devices?

>That would be a workaround.  It should definitely work.

I'll be out of town for the next two days but am happy to test and provide
info when I return.  I still consider myself a 'newbie' so do not be afraid
to ask obvious questions.

Thanks for your help!


More information about the freebsd-questions mailing list