Default gateway PPP

"Thärning Peter, Stockholm konsult" peter.tharning at
Thu May 15 09:45:35 PDT 2003


I am actually using an own port of the FreeBSD (elderly version) in an embedded (16 bit) application.

This application communicates via http/tcp/ip/ppp (modem) only.

It has worked pretty well until I recently should make it connect via a GPRS modem.

I have tested this GPRS modem in Win98, and the difference in settings is that the checkbox "Use default gateway" _must_
be checked.

Now, I have twinkled IP addresses forward and backward in my own "clone" of FreeBSD but just can't get the ip packets out and back again.

The PPP link with all its protocols gets up fine, the addresses is negotiated via ipcp etc., but when it comes to the first udp dns request, the packet
is just sent out there with no return. (And as written above, this worked ok until the demand of using the default gw come up...)

(Ps. I know that the checkbox "Use def..." in Win98 adds a new line in the routing table. But in my own "clone", I have no route table, I just do 
point to point communication through PPP, and don't know what's wrong. Ds.)

Do You have some small hint what could be the issue here?

Best regards, Peter Tharning

More information about the freebsd-questions mailing list