How to make Mozilla display Korean (or CJK-type) characters?

Bernd Walter ticso at
Mon May 12 05:30:20 PDT 2003

On Sun, May 11, 2003 at 12:47:57PM -0400, Joe Marcus Clarke wrote:
> On Sun, 2003-05-11 at 11:28, Rob Lahaye wrote:
> > Bernd Walter wrote:
> > > On Tue, May 06, 2003 at 12:00:49PM +0900, Rob Lahaye wrote:
> > > 
> > >>I seem to remember that Mozilla somehow out-of-the-box could display
> > >>non-roman charactersets, such as Korean. But Mozilla doesn't seem
> > >>to do that anymore. What should I do ?
> > >>
> > >>I have installed the Korean johabfonts-port, which mentions something
> > >>about Mozilla in its pkg-descr file. I installed it and included the
> > >>directory in my fonts for X11; to no avail.
> > >>
> > >>In Mozilla I can select as the character set "Korean(JOHAB)", but when I
> > >>check it next time, it is again on "Korean(EUC-KR)".
> > >>
> > >>Non-roman characters are displayed as squares that seem to have four tiny
> > >>roman characters in them.
> > >>
> > >>Is this a bug in Mozilla, or is my fonts setup buggy, or is this a
> > >>more fundamental FreeBSD issue?
> > > 
> > > 
> > > I had the same problem.
> > > Compile the mozilla port with -DWITHOUT_XFT=yes.
> > 
> > Indeed that did it!
> Can you give me a site using the characters in question?  I have no
> problem displaying non-Roman (Cyrillic in this case) characters, as well
> as Japanese Kanji in Mozilla _with_ Xft support enabled.  In fact,
> looks fine to me, too with Xft.

I tested with
The characters were displayed as a square with 4 hex digits in them
I guess the number were Unicode or something like this.

> With all font issues in Mozilla, you must have fontconfig, freetype2,
> and Xft ports up-to-date.  If you add new fonts, make sure you add them

IIRC these were recent when I first noticed this problem.

> to /usr/X11R6/lib/X11/fonts, ~/.fonts, or, if another location, make
> sure you add that location to /usr/X11R6/etc/fonts/local.conf per the
> instructions at

Sound like much to read - and given that I run XFree86-4.2.0_1,1 on
my display.
Are you expect this might a problem on the X-server?
I had not thought about this, because no-roman fonts always worked
until then.

> Then run fc-cache -f as root.

Well - this is the server side for shure.

B.Walter                   BWCT      
ticso at                                  info at

More information about the freebsd-questions mailing list