Can't install fontconfig

Roger Merritt mcrogerm at
Sun May 11 23:03:07 PDT 2003

I seem to have continual trouble with the port fontconfig. Last month I 
solved the problem by deleting everything in my True Type fonts directory 
and copying over just the fonts I wanted from my Wondoze machine. After 
that fc-cache ran correctly and I was able to install the upgrage to 
2.1.93. So now the port has 2.2.0, and when I try to install it I get:

>Running fc-cache to build fontconfig cache...
>fc-cache: "/usr/X11R6/lib/X11/fonts": caching, 0 fonts, 16 dirs
>fc-cache: "/usr/X11R6/lib/X11/fonts/100dpi": caching, 0 fonts, 0 dirs
>fc-cache: "/usr/X11R6/lib/X11/fonts/75dpi": caching, 0 fonts, 0 dirs
>fc-cache: "/usr/X11R6/lib/X11/fonts/PEX": caching, 0 fonts, 0 dirs
>fc-cache: "/usr/X11R6/lib/X11/fonts/Speedo": caching, 0 fonts, 0 dirs
>fc-cache: "/usr/X11R6/lib/X11/fonts/TTF": /usr/libexec/ 
>ib/ Undefined symbol "FT_Get_BDF_Property"
>*** Error code 1
>Stop in /usr/home/ports/x11-fonts/fontconfig.
>*** Error code 1
>Stop in /usr/home/ports/x11-fonts/fontconfig.

For some reason portupgrade has deleted fontconfig from the installed ports 
database. This hasn't caused me any problems yet in running programs that 
supposedly depend on it, but whenever I try to run 'pkgdb -F' I get hung up 
with a "stale dependency". When I run 'portversion -c' it reports that 
fontconfig-2.1.93 needs to be updated to 2.2.0. When I run 'portupgrade -rf 
fontconfig' it tells me no such package is installed and I go back to 
either 'portupgrade -Nrf' or 'portinstall'.

What can I do about this "undefined symbol" in 
/usr/X11R6/lib/", which appears to be the problem?


More information about the freebsd-questions mailing list