Adaptec SCSI controller problem

Doug Hardie bc979 at
Sun May 11 22:13:46 PDT 2003

On Saturday, May 10, 2003, at 16:57 US/Pacific, Andy Farkas wrote:

> On Sat, 10 May 2003, Doug Hardie wrote:
>> I have a system with a Adaptec 2940 Ultra SCSI adapter controller.  
>> The
>> original configuration had 1 disk internal and nothing external.  The
>> external connector had nothing plugged into it.  All worked fine.
>> However, I tried to add a DLT drive to the external connector.  On
>> boot, the system hung because it couldn't find the disk.  Its supposed
>> to  boot off the SCSI drive.  Running the adaptec scsi utilities it
>> found both the internal disk and the external DLT drive.  The disk has
>> id 0, the DLT 5 and the controller 7.  So, I removed the cable from 
>> the
>> system as I just didn't have time to address that issue at the moment.
>> However, it still hung at the same point in the boot.  No sequence of
>> disconnection of cards, disks, connectors etc. would bring back the
>> boot capability.  It consistently gets an error message that there is
>> no terminator.  So, I added a terminator on the external jack.  It now
>> boots properly.  Something has obvioulsy changed but I can't figure 
>> out
>> what it is.  I still need to use the DLT - with the drive, and I need
>> to return the terminator as its borrowed.  Any ideas on how to make
>> this work?  Thanks.
> Turn off termination on the card (using bios uitility).
> Make sure both the disk and the dlt drive have termination enabled.

Thanks for the tip.  That worked.  I don't know why since the 
descriptions of the termination settings in the user's guide has 
multiple descriptions (different) for the various settings.  I just 
tried each till I found one that works.  I was able to get the DLT to 
work and recovered the data I needed and then got the system to work 
without the terminator afterwards.

More information about the freebsd-questions mailing list