newbie quest: freeBSD 4.8-rel, running X fails on my laptop w. an ATI Radeon IGP 340M

Mikael Lönnqvist Mikael.Lonnqvist at
Thu May 8 07:35:16 PDT 2003

Hi all,
I'm having a problem running X on my Laptop, FreeBSD-4.8-release, Xfree86 Vers. 4.3.0 (out of ports) 
The laptop (Fujitsu, 2Hgz, 512MB RAM) has an ATI Radeon IGP 340M, 32MB graphics
chip in it. It's running on PCI bus 1, device 5, funct0. 

I'm getting this error msg:

(EE) No devices detected
Fatal server error: no screens found

tailing /var/log/XF86Config.0.log produces the same as above. 

No matter what i try, I can't seem to get it working...

A colleague of mine running Mandrake 9.1 has an identical machine as mine, and has hot Xfree86 4.3.0
Working - so i tried copying his XF86Config file,,, except for the fonts statements,
which has been changed/modified in Mandrake in order for to use it's own font server.

Doesn't help... and I don't want to run Mandrake;-)

I't looks like the Radeon chip is not found, doesn't it? (according to the Error)

Anywone got a clue? I've tried searching everything everywhere via Google but 
have come up with nothing useful.

Please accept my apologies if this is the wrong forum, or if i'm posting this in some way i should not

Best Regards

More information about the freebsd-questions mailing list