2 Major problems after fresh installation

clayton rollins crollins666 at hotmail.com
Wed May 7 19:54:20 PDT 2003

>On Wed, 7 May 2003 10:19:23 "Eddy Ramos" <e.ramos at deepground.com> wrote:
>Hi there,
>I have used some Linux (Redhat, Suse) and UNIX (SCO) before, but I am
>relatively new to FreeBSD.
>I have 2 major problems after installing FreeBSD 4.8 on a PIII 866Mhz
>system (256 MB RAM).
>These are my problems, starting with the most important:
>1) Can't get the network cards to work properly. I see something like
>'couldn't map ports/memory' during startup.
>The machine is meant to be used as a router, so it has two network
>	1. 3Com 3C905B-TX (uses IRQ 9 in Windows). I know this card is
>supported by FreeBSD (xl driver according to hardware list)
>	2. Realtek RTL8139 (uses IRX 10 in Windows). I know this card is
>supported by FreeBSD (rl driver according to hardware list)
>When I use /stand/sysinstall -> Configure -> Networking -> Interfaces I
>only see the parallel port (lp0) and the COM1 and COM2 devices.
>Furthermore I see 'faith0 <unknown network interface type>' that's it.
>Please have a look at the messages and the ifconfig output in order to
>see what is going wrong.
>2) Xwindows (and KDE window manager) won't run.
>I have an Iiyama Vision Master monitor and an NVIDIA GeForce2 MX card
>(nv driver according to hardware list)
>	1. Yes, I have installed the X wrapper (installed as a
>dependency by default);
>	2. Yes, I have a raised security level (Raising kernel security
>level: kern.securelevel: -1 -> 2);
>	3. Yes, I have tried to 'startx' both as a user and as root;
>	4. Yes, I have tried both the 'xf86config' and the 'xf86cfg
>-textmode' tool to create the config file.
>Please have a look at the log files in order to see what is going wrong.
>Could anyone help me sorting this out?
>Thanks anyway,

Hi Eddy,

Don't know how much it helps you, but I can tell you I've used those three 
dev.s/drivers in my computer for sometime with no error. (An incompatability 
between bsd and your bios seems likely.)

About running X with raised security levels. (I'll assume you already know 
of the mem. access problems here.) You could try the aperture workaround by 
Thomas Moestl. You can get sources at 
http://people.FreeBSD.org/~tmm/patches/ . (I'm not sure which diff you want, 
or either of them applies to your version, or even if it's already been 
integrated, but it's there.) You can get some background info from the 
readme at http://www.tu-bs.de/~y0015675/README.aperture .


STOP MORE SPAM with the new MSN 8 and get 2 months FREE*  

More information about the freebsd-questions mailing list