Back/restore with dd

Pietralla, Siegfried P siegfried.pietralla at
Wed May 7 19:37:50 PDT 2003


i've noticed the same thing. i was trying to duplicate my installation from
ad0s1 to ad0s2 by copying each partition and had the same problem. i worked
around this by using 'of=/dev/ad0' and VERY careful use of the 'seek'
parameter ( e.g. " dd if=/dev/ad0 count=10 skip=nnnnn | od -c > /tmp/001 "
and match this with " dd if=/dev/ad0s1e count=10 | od -c > /tmp/002 " using
" sdiff /tmp/001 /tmp/002 " to validate the value for seek ).

is there someone out there who knows how we can do this? fwiw, i think it
used to work previously (  v 2.2.8 ? ) but it fails at 4.6 ( ? ) . i'm
running 4.8 now so i'll give it another go on the weekend.


-----Original Message-----
From: Paul English [mailto:penglish at]
Sent: Wednesday, 7 May 2003 3:30
To: freebsd-questions at
Subject: Back/restore with dd

So in the process of trying to recover my files, I made a backup copy of a
partition using dd. I did:

dd if=/dev/ad1s2e of=ad1s2e

So I created a file, the size of the partition sitting on another disk

Now I want to copy that back to another disk partition. I tried just using
dd, but that didn't work:

dd if=ad1s2e of=/dev/ad1s1e

dd if=ad1s2e of=/dev/ad1s1e
dd: /dev/ad1s1e: Read-only file system
2+0 records in
1+0 records out
512 bytes transferred in 0.026033 secs (19667 bytes/sec)

I have created ad1s1e (which is a different physical disk) as a partition
with the same block count as ad1s2e. I used /stand/sysinstall, so it
should have had the same defaults for everything, correct?

What am I missing? Why would it say read-only file system, and then
proceed to transfer only a couple of bytes?



freebsd-questions at mailing list
To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"

More information about the freebsd-questions mailing list