New server keeps panicking

Derek Ragona derek at
Wed May 7 12:06:12 PDT 2003


Here are my answers to you . . .

At 05:49 AM 5/7/03 -0700, cp wrote:
>Derek,  I can't post to the list from my ISP but receive the messages. Feel
>free to post my stuff too since I'm most curious if anyone watches that list
>that has indepth knowledge of the AHD drivers.
>I have had identical problems with the new dual xeon I'm putting up. 5.0 did
>exactly as you describe and the problem became constant when I put two
>drives in rather than one. I turned debug on the SCSI controller and the
>error was occurring because a disk would get a SCSI Timeout under hard IO
>and the driver would disable the pack, then it times out on the write. I bet
>this occurred most often under the Ports since you begin to do a lot of
>Output fast at that point. I'm assuming you don't have the newest 4.8 and
>that possibly the version you have shares the SCSI driver with 5.0. I have
>more information on how it occurred under 5.0 but have moved away from that
>I ordered and installed the April 4.8 because from what I could tell changes
>were made to ahd in february / march timeframe based on a single post I
>found in the archives. The errors went away except for a nagging B channel
>card state dump that seems innocuous but still concerns me enough to hold
>off delivery. Thus I'm very interested in your problem as it indicates it's
>a FreeBSD issue and not a hardware problem.  This weekend I ran massive IO
>tests to both disks under 4.8 with the drives on A channel and had no
>problems at all. I'm left now only with just an odd error message but have
>caution. I have the details posted in comp.unix.bsd.freebsd.misc under two
>messages with "Supermicro" and Adaptec in the title including configuration
>and dmesg output for the 4.8 installation. No one responded except for one
>person suggesting 4.8. I think this problem requires the attention of
>someone intimate with the driver code.
>Is there any commonality aside from being dual SMP? My configuration is:
>Dual Xeon 2.6 2GB Ram on Supermicro X5DA8 motherboard E7505 Chipset
>Adaptec aic7902 onboard controller (29320D) with GEM318
>Intel Gigabit
>dual Cheetah ST336753LC drives.
>The B channel controls the top three slots of my SCSI bay, the A channel
>controls the bottom four.

The system I have is an Intel SE7501WV2 SCSI motherboard.  So it has the 
7501 chipset.
Dual Xeon 2.66 CPU's
Adaptec aic7902 onboard SCSI controller
Dual Intel Gigabit ethernet
One Fujitsu 72 GB U320 SCSI drive
The SCSI drive is on the B channel!
The A channel is the external port.

>These error conditions and warnings have nothing to do with configuration of
>the kernel though now I am running a full hyperthreaded SMP and it works
>great. An offshoot of going to 4.8 is that the drives now have been
>relegated to 160Mhz rather than the 320 they were getting on 5.0. If there
>is a commonality here, my guess would be that your placing your disk on the
>A channel and running the latest (April 03) release of freebsd 4.8 will make
>your system work.

I will try a snapshot of 5.0, and 4.8 and see if either works.

The system panicks as soon as the boot finishes.  What is weird is the 
loading works fine.  So there must be a kernel difference between the 
kernel that boots from the CD and the generic kernel installed.


>At this point it appears we may be the only two sharing this problem so keep
>in touch.
>Chris Pratt
>----- Original Message -----
>From: "Derek Ragona" <derek at>
>To: <freebsd-questions at>
>Sent: Tuesday, May 06, 2003 9:49 PM
>Subject: New server keeps panicking
> > I am installing a new server, it is using an Intel SE7501WV2 motherboard
> > with on-board SCSI.  This Motherboard has 2 intel Xeon 2.66 GHz CPU's.
> >
> > The system has one IDE CD-ROM, and one SCSI U320 hard disk.  The SCSI disk
> > is cabled using an Adaptec U320 cable, with terminator.
> >
> > I have tried installing FreeBSD version 5.0 release, but it kept panicking
> > with SCSI disk write error messages.  So I tried again, installing this
> > time version 4.8 release.  The 4.8 had the same problems.
> >
> > Is there something I need to do because of the SCSI disk system?  Or is it
> > the two CPU's?
> >
> > The error I get is a block cannot be written, it is out of range.  The
> > system actually locks up, something I have never seen FreeBSD do.
> >
> > I looked and don't see any issues about this motherboard or U320 drives in
> > the problem reports or message archives.
> >
> > Any help would be appreciated.  Please reply to me, I don't subscribe to
> > this list.  Thanks.
> >
> >
> >          -Derek
> >          derek at
> >
> >
> > _______________________________________________
> > freebsd-questions at mailing list
> >
> > To unsubscribe, send any mail to
>"freebsd-questions-unsubscribe at"
> >
> >

More information about the freebsd-questions mailing list