FreeBSD Installation Problems

John Murphy jfm at
Sat Mar 29 05:40:51 PST 2003

"Sukhbinder Singh" <sukhbinders at> wrote:

>I did what you asked me to do. This time I had a little bit of progress but
>still I got a differen error message. I used the windows command winipcfg
>command to get the DNS information. As I indicated in my previous mail there
>are 6 fields in the windows in the "Network Configuration" window where
>these 6 fields are  host, domain, ipv4 gateway, name server, IPv4 address
>netmask : , extra option to ifconfig.
>The hostname I typed as :-   foo
>The domain name as you indicated in your mail that you used my.domain I also
>used my.domain
>The netmask automatically chaged to :-
>The name server address or the DNS address after checking using winipcfg
>was: but when I use the arp command it gives me a different
>address instead. It gives me instead. The ipv4 gateway
>information is blank with no information on this. The IPv4 information is
>also left blank with no information  and the extra option to ifconfig is
>also left blank with no information. I chose to download using FTP. after
>keying in all the information like the login name, password and the
>telephone number for my ISP, I tried connecting, I got an error message like
>" Cannot resolve hostname '' ! Are you sure that your name se
>rver, gateway and network interface are correctly configured ?" then I
>pressed enter after this I got another message like "Killing previous PPP
>process 34". Can anyone help regarding this problem. Any help will be

I have confirmed that there is a Name Server at and that it
correctly resolves

> dig @

; <<>> DiG 8.3 <<>> @
; (1 server found)
;; res options: init recurs defnam dnsrch
;; got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 6
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 3, ADDITIONAL: 3
;;, type = A, class = IN

;; ANSWER SECTION:        5M IN CNAME    1m20s IN A

;; AUTHORITY SECTION:        3d13h36m43s IN NS        3d13h36m43s IN NS        3d13h36m43s IN NS

;; ADDITIONAL SECTION:      3h12m54s IN A      3h12m54s IN A            1h35m59s IN A

;; Total query time: 1155 msec
;; WHEN: Sat Mar 29 12:55:48 2003
;; MSG SIZE  sent: 33  rcvd: 213

I am surprised you still get Cannot resolve hostname ''.
But you would probably see that error if PPP was not 'up'.

To confirm whether it is a Name Server problem, you could choose 'other'
when asked to select a FreeBSD FTP distribution site and set as the address.

If it still doesn't work.  Have a look on vty3 (press Alt-F3) and confirm
that PPP is indeed 'up'.  You should see something like PPP ON foo.
(All three Ps must be capital letters).

I think you are very close to getting this working.  Don't give up.

Please remove freebsd-hackers from the list of addresses you are contacting.


More information about the freebsd-questions mailing list