Installation Woes

John McClure chromodromic at yahoo.com
Thu Mar 27 01:31:29 PST 2003


Argh.

Since my original install wouldn't accept a root
partition of 256M and since I had no idea what the
minimum should be, I just upped that allotment to 1G
and happiness ensued. After this, my installation
appeared to proceed normally.

Almost.

When the installation started I got an error, which
I've gotten on subsequent attempts:

"Error mounting /mnt/dev/ad0s1f on /mnt/usr : Invalid
argument"

This is making me very sad. Firstly, the /usr mount is
allocated the vast bulk of my hard drive space, about
23G. From what I understand, this shouldn't really be
an issue, and I've supplied a newfs argument:

newfs -f 2048 -b 16384

The first time the installation completed and I tried
to reboot, I got a bunch of error messages informing
me that I had an "INVALID FILESYSTEM: Check with
fsck", and then got subsquently dropped into a %
prompt as root. The filesystem was read-only and the
fsck I ran there told me that there was a problem with
/mnt/usr and /mnt/var.

So ... ideas? Any suggestions on another course to
take. I'm going to install FreeBSD on this system if I
have to pry the hard drive open and hand copy the bits
with a magnetic needle. But since that would obviously
take some time, I'd prefer it if someone had any
insights.

Also, I'm still trying to figure out what to do about
multiple INDEX entries warning following a "make
index" after a ports cvsup, so if anyone's got any
ideas on that, too ...

Thanks in advance for any help. It is appreciated.

Peace,
GM

__________________________________________________
Do you Yahoo!?
Yahoo! Platinum - Watch CBS' NCAA March Madness, live on your desktop!
http://platinum.yahoo.com


More information about the freebsd-questions mailing list