bge network driver not loaded on a HP (Compaq) Proliant DL380 G3

David Landgren david at
Wed Mar 26 18:01:49 PST 2003

Nicolas Kowalski wrote:

>David Landgren <david at> writes:
>>I am in the process of installing FreeBSD 4.7 on an HP Proliant DL380
>>G3. At the moment I am blocked by the fact that the kernel does not
>>recognise the network card (or rather, does not load the bge driver).
>I faced the same problem with a ML370 G3. My ugly workaround was to
>plug in this machine another - well recognized - network card. I used
>an Intel EtherExpressPro10/100 (fxp) for this.
Just for closure's sake on the list, here's what I did.

As I was loading the 4.8-RC2 iso, playing around with this a bit more I 
seemed really close to success. In /boot/loader.conf I added


The drivers load correctly; I can see them when I run 'kldstat'. What I 
seem to be missing, though, is an explicit way of creating bge0 and 
bge1. I tried adding

ifconfig_bge0="inet a.b.c.d netmask"

in rc.conf, but it still failed to create the interface. After futzing 
around reading rc and, the download finished. I burnt the CD, 
booted it, and opening the emergency holographic shell on vty4, I saw 
that bge0 and bge1 existed.

I'd rather not have to put an RC2 of anything into production, but I'll 
keep my fingers crossed. The other alternative was to install redhat 7.3 :o(


More information about the freebsd-questions mailing list