BTX halted

Roger Merritt mcrogerm at
Mon Jun 30 19:01:00 PDT 2003

I recently got a new, large hard drive for one of my two servers and 
transferred everything over from the old 4GB drive. So then I wanted to 
take the old drive and combine it with the other old drive -- my idea is to 
transfer /usr/home to one of them and leave the rest of the system on the 
other. We also got new machines for our students, which gave me another box 
that is just a little better than the box I'm currently using -- 200MHz 
instead of 166MHz. The thing is, I'm not entirely sure what chip is in the 
200Mhz box. The old hard drive was compiled for an i686, while the other 
server is compiled for an i586.

So I plugged the old hard drive in and tried to boot up. I got a screen dump:

BTX Loader 1.00 BTX version is 1.01

int=00000006  err=00000000  efl=00010246  eip=00001934
eax=00021d60  ebx=00000000  ecx=00000000  edx=ffffffff
esi=00000000  edi=00020c34  ebp=00094bec  esp=00094bdc
cs=0026  db=0033  es=0033  fs=0033  gs=0033  ss=0033
cs:eip=0f 44 d6 89 55 fc 46 83-2c b7 00 74 05 83 fa ff
ss:esp=00 00 00 00 00 00 00 00-00 00 00 00 ff ff ff ff
BTX halted

So I took the drive back to its original box, booted up with no problem, 
recompiled the kernel with *both* i586 and i686 in the CPU type section, 
booted up again to make sure it worked. Took it back to the other box -- 
same problem. BTX halted. Took it back to the original box and recompiled 
as GENERIC. Booted up to make sure it worked, took it back to the other box 
-- same problem.

I've done a google search without finding anything that helps. Can anyone 
suggest a solution? I can boot up with a floppy and run the fixit disk on 
the new box, so I may end up just wiping the disk and making a clean 
install, but if I can preserve the working system it would be nice. Also, I 
would have to install over ftp, which takes quite a while.


More information about the freebsd-questions mailing list