5.1-RELEASE & Windows XP dual-boot issues

Scott Reese sreese at codysbooks.com
Mon Jun 30 15:29:53 PDT 2003

On Mon, 2003-06-30 at 22:14, Doug White wrote:
> On Mon, 30 Jun 2003, Andrew Boothman wrote:
> > This seems to be a recurring problem after 5-RELEASE. I had exactly the same
> > problem, and I know of others that are the same. For some reason -current
> > doesn't seem to be inter-operating well with the WinXP/Win2k loader anymore.
> > I'm not sure if it's only happening to some installations - but I was
> > certainly in the same boat.
> >
> > I ended up having to re-install Win2k and I used Grub as my new bootloader.
> Can't say I'm having any boot0 issues here with -current and win2k pro
> sp3.  Note windows is partition #2 and about 40GB in.

I think it's something particular about the way the 5.1-RELEASE install
works.  As I mentioned in the original post, I had 5.0-RELEASE installed
in this configuration and my dual-boot setup worked just fine. 
Subsequent source upgrades to 5.1-PRE also worked fine.  After a fresh
install of 5.1, kaboom.  I have a hunch that it has something to do with
5.1 defaulting to UFS2 and it's subsequent handling of filesystems
originally created with UFS1.  Seems to me I saw something about this on
the -current list a while ago but I don't remember the particulars.


More information about the freebsd-questions mailing list