Bootloader WOES

Remington L. cableboy at
Wed Jun 25 15:55:46 PDT 2003

Part 1

I have an old HP NetServer LH Pro that had NetBSD 1.6.1 on it. 
The NetServer is a P166, 64MB RAM 2GB SCSI drive(comes up on da0)

Last night I attempted to install FreeBSD 5.1-R. Everything ran smoothly
until I reboot. At the boot loader screen F1: FreeBSD, I hit F1 and it went
to the NetBSD screen and tried booting netbsd.gz. This is seemingly impossi

Is there a way to reinstall the boot loader without the entire OS?

Part 2

Ideally I would like to install grub but that is also plagued with problems.
I went in to the LiveFS. Mounted my drives, created the config file and all
that, Rebooted and booted off the GRUB floppy and tried to install, by
issuing the following: 
install (hd0,1,a)/boot/grub/stage1 (hd0) (hd0,1,a)/boot/grub/stage2 p

It comes back with "Error 22: Nu such partition". To the best of my
knowledge this is correct. The root partition is on da0s1a. What am I

More information about the freebsd-questions mailing list