contigmalloc1 panic on install

Ryan Carmichael bremen at
Wed Jun 25 13:59:58 PDT 2003

I've recently tried to install both 5.1 Release and 4.8 Release on a Toshiba
laptop and I get this error:

panic: contigmalloc1: size must not be 0

during boot up (see full boot text below).  4.8 will actually install fully
before giving this error, but 5.1 won't even get that far.  From doing some
reading it seems to be an ACPI error but with 5.1 the option to "boot with
ACPI disabled" gives the same result. Possibly it is an AGP error since that
is the last line before the panic (see below).

I'd appreciate any pointers, though buying a new laptop may be in order :)

Please reply to my e-mail address as I am not on this list.

Ryan Carmichael

(This text is from an attempt with ACPI enabled; with it disabled the output
is slightly different but end result is the same)

Timecounter "i8254" frequency 1193182 Hz
Timecounter "TSC" frequency 851940500 Hz
CPU: Intel Pentium III (851.94-MHz 686-class CPU)
Origin = "GenuineIntel" Id = 0x686 Stepping = 6
real memory = 125763584 (119 MB)
avail memory = 110366720 (105 MB)
Pentium Pro MTRR support enabled
md0: Preloaded image </boot/mfsroot> 4423680 bytes at 0xc06877a4
npx0: <math processor> on motherboard
npx0: INT 16 interface
acpi0: <TOSHIB 750 > on motherboard
pcibios: BIOS version 2.10
Using $PIR table, 6 entries at 0xc00f01d0
acpi0: power button is handled as a fixed feature programming model.
Timecounter "ACPI-safe" frequency 3579545 Hz
acpi_timer0: <24-bit timer at 3.579545Mhz> port 0xee08-0xee0b on acpi0
acpi_cpu0: <CPU> on acpi0
acpi_tz0: <thermal zone> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
agp0: <Ali Generic host to PCI bridge> mem 0xf8000000-0xfbffffff at device
0.0 on pci0
panic: contigmalloc1: size must not be 0
Uptime: 1s
Terminate ACPI

More information about the freebsd-questions mailing list