(noperiph:sym0:0:-1:-1):SCSI BUS reset delivered. -- HP Netserver LH3r

Etienne Ledoux etienne at unix.za.org
Wed Jun 25 07:12:48 PDT 2003

Ok i fixed my subject a bit.

Well I've tried FreeBSD (4.4, 4.8, 5.0), SuSE Linux 8.1, Redhat 9.0.
All these operating systems fail to detect the hdd and when trying to load the 
scsi drivers for it it gives timeout errors (redhat & suse).

FreeBSD gives: (noperiph:sym0:0:-1:-1):SCSI BUS reset delivered.
			(noperiph:sym1:0:-1:-1):SCSI BUS reset delivered.

This made me think that it might be a problem with the hardware configuration.
I've got two exactly the same machines. Both give exactly the same error.

I changed the scsi configuration on one machine. Trying different settings. No 
change. (except for the few times where my changes disabled the hdd and it 
couldn't find any OS). I installed the FreeBSD putting the drives into 
another HP server (which btw also happens to be a Netserver LH3r), and 
putting them back afterwards. Booting of the cd gives the same error.

What does the error: "(noperiph:sym0:0:-1:-1):SCSI BUS reset delivered" 
actually mean ? What is FreeBSD actually complaining about ?

I would assume that these HP servers (we have inhereted a few of them) would 
use the same type of hardware. The server I'm trying to install this on is a 
HP cluster server which has an external Raid Storage (which is currently 
disconnected from the servers). The servers themselves are HP Netserver 
LH3r's. The standalone server I used to do the install on is also a HP 
Netserver LH3r. The only noticeable difference between the standalone server 
and the server in the cluster is that the standalone server has a single 
processor and the cluster servers are dual processor. I've removed the SCSI 
card which is used to connect the server to the external Raid Storage and the 
installation still gives the same error.

Now I could start to think that the hardware might be busted, but these 
servers were still running Redhat 7.1 a few days ago.

If I want to try using the NCR driver (mentioned below), How would I go about 
doing that ?
What else could I try.

Maybe if I understood the error((noperiph:sym0:0:-1:-1):SCSI BUS reset 
delivered) a little better, I could try a few other things.

hints/tips/anything appreciated.

Another weird thing I noticed:
- While another guy was installing FreeBSD on an HP pizzabox he also got this 
error: "(noperiph:sym0:0:-1:-1):SCSI BUS reset delivered", but it continued 
to boot and he was able to install the box. hmmmmm ?


On Tuesday 24 June 2003 20:23, you wrote:
> On 2003-06-24 15:33 +0200, Etienne Ledoux <etiennel at datapro.co.za> wrote:
> > Greetings
> >
> > I'm trying to install FreeBSD on a HP Cluster Server. But when I boot
> > with the CD's ( 4.4, 4.8 & 5.0 ), it will boot all the way upto "Wait 15
> > seconds for SCSI devices to settle" and then it immedialty give the
> > following message:
> >
> > (noperiph:sym0:0:-1:-1):SCSI BUS reset delivered.
> > (noperiph:sym1:0:-1:-1):SCSI BUS reset delivered.
> >
> > After this the machine is basically unresponsive/dead.
> >
> > Any idea what could be causing this and what I could do to fix it ?
> Depending on the SCSI chip you may want to try the NCR driver
> instead of the SYM driver. (The SYM driver is an enhanced
> version of the NCR driver, but I've heard before, that the NCR
> driver may work in (the extremely few) situation where the SYM
> driver fails).
> Please send a boot message log and complete error messages and
> I'll see whether they help ...
> Regards, STefan

More information about the freebsd-questions mailing list