Xfree86 Config Problems

bsd at sleve.mailshell.com bsd at sleve.mailshell.com
Tue Jun 24 09:22:27 PDT 2003

Thanks for prompt reply, guys.  I enjoy this community, but hate the install.  

While I didn't mention it in my email, I did try this as well:
> > # XFree86 -configure
And it didn't work.  Gave me X cursor in gray screen and could not get out.

As for checking for multiple config files, how would I know?  Where would I find them? What would I do with them all, just rm them?  What if I found more than one?  How do I know which one is being used?  Why so many config utils?  Why are there so many possible locations? 

This is my first install of BSD, and while I've installed Linux a dozen times, I don't know where to find things in BSD.  I'm overwhelmed and frustrated.  Please walk me through the steps before I give up on BSD.  

I wonder if my S3 Savage 2000 video card is supported, even though it was on the list.  I saw many posts about S3 problems, none with obvious solutions.  I could use the FreeBSD 5.1 Release if that would help.  I saw this link about S3 Savage at http://www.xfree86.org/support.html a private developer at  http://www.probo.com/timr/savage40.html where he says:  "xvideo on the Savage2000 still seems to be broken. I don't know when I'll be able to get around to this." 

Thus far, the install process is overly complicated and not inviting to new users.  I could provide specific feedback on this if anyone wants it.

>From Viktor Lazlo <viktorlazlo at telus.net> on 23 Jun 2003:

> On Sun, 22 Jun 2003 bsd at sleve.mailshell.com wrote:
http://cgisleve.tripod.com/bsd/xfreebad.html is a web page of this info.
> >
> > XFree86 Configuration Problems
> >     by Steve LeBlanc © 2003.6.22
> > Installed FreeBSD for first time.  Text login was fine. NIC worked.
> Did a telnet and ftp to computers on the Internet. All seemed to work
> except for configuring XFree86. No screen found when I did startx. Below
> are the details:
> >
> > The full commented files: XF86Config.txt and XFreelog.txt
> >
> > Settings
> > XFree86 Ver:4.2.1 
> > Release Date: 3 September 2002
> > OS: FreeBSD 5.0 RELEASE
> > Video: S3 Savage2000 (generic) 64MB, 3D
> > Monitor: Cornea MT1700 17" LCD H: 31.5-80, V: 56-75
> >
> >
> > After install I tried both: xf86cfg -textmode and xf86config to
> > reconfigure. I read the docs deeply and redid this 15 times, using the
> > various command line tools. Each of the last 10 times, I typed in my
> > settings and selected my Graphics card from the list. I just can't get
> > startx to work. Below are my XF86Config file and my XFree log file,
> with comments removed.
> >
> > Fatal server error:
> > no screens found
> Check the handbook:
> 5.4.2 Configuring XFree86 4.X
>    Configuration of XFree86 4.X is a multi-step process. The first step
> is to build an initial configuration file with the -configure option to
> XFree86.   As the super user, simply run:
>      # XFree86 -configure
> Cheers,
> Viktor

The FREE service that prevents junk email http://www.mailshell.com

More information about the freebsd-questions mailing list