New hard drive, old BIOS?

Roger Merritt mcrogerm at
Sun Jun 22 04:05:28 PDT 2003

I've just installed a new, 40GB hard drive, and copied my system over to 
it. It booted and seems to be running fine, but I have a couple of worries.

1. My BIOS setup utility doesn't detect the drive using the Auto Detect 
Hard Drives feature. In fact, when I tried to run it, it hung. However, 
when I just went ahead and booted FreeBSD (on my old hard drive) it didn't 
seem to have any problem seeing and writing to the new drive. Is this a 
serious enough problem to take the risk of trying to flash an upgrade to my 

2. When I booted up using the new hard drive, everything seemed to go OK 
for a while, then I got a number of error messages on the console: "ad0s1a: 
UDMA ICRC error reading fsbn 96639 of 48288-28369 (ad0s1 bn 96639; cn 6 tn 
3 sn 60) falling back to PIO mode". Would this be the likely result of an 
outdated BIOS (the blurb says "copyright 1998")? Or is it more likely the 
result of old cables which don't meet the ATA66 spec?

Subjectively, the machine seems to be running somewhat faster, despite the 
lack of DMA (I don't know if DMA ever worked on this machine). And it's a 
great relief to now have plenty of free space.


More information about the freebsd-questions mailing list