fsck'ing UFS partitons under linux?

Han Hwei Woo hhwoo at argosy.ca
Fri Jun 20 04:58:03 PDT 2003

I believe UFS support is still experimental on Linux. Last time I tried it,
I managed to mount my UFS partitions read write, but it ended up completely
destroying them, so I'd approach this with extreme caution.

Han Hwei Woo

----- Original Message ----- 
From: "derrich" <derrich at freebsdhackers.net>
To: <freebsd-questions at freebsd.org>
Sent: Friday, June 20, 2003 2:48 AM
Subject: fsck'ing UFS partitons under linux?

> I'm trying to fsck a UFS (created under FreeBSD 4.8) partition from within
> a Linux system, and I'm having a whole lot of trouble. I know UFS support
> is enabled in the kernel, because I'm able to mount the drive read-only. I
> believe I've been unable to mount it read-write because the drive needs to
> be fsck'ed, but I can't figure out how to do this under linux.
> I've tried running 'fsck -t ufs /dev/hda2', but I get an error about
> /sbin/fsck.ufs not existing ... and googling 'fsck.ufs' turns up very
> little, and what little it turns up isn't all in English, which doesn't
> really help me.
> If anyone has any suggestions, it'd be appreciated.
> Derrich
> _______________________________________________
> freebsd-questions at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to
"freebsd-questions-unsubscribe at freebsd.org"

More information about the freebsd-questions mailing list