Alexandru Savescu alex at
Thu Jun 19 07:25:27 PDT 2003

Hello BSD-lovers, 
i'm stuck on a tricky situation:

i got FreeBSD 4.8-STABLE running smoothly on a SCSI disk, 
but i had to move the HDD on a multi-OS system, so i am 
heading this problem:

there are 3 disks
- ad0: IDE WDC-drive with a MSwinOS
- da0: SCSI IBM-drive with Debian Linux
- da1: SCSI IBM FreeBSD disk

ad0 is the primary disk with lilo in the MBR

lilo.conf uses 

/dev/sda1 to boot the debianOS
/dev/sdb1 to boot FreeBSD

well, this is working fine for winOS and linux but FreeBSD
returns this error lines:

Root mount failed: 22
Mounting root from ufs:/dev/da2s1a
Root mount failed: 22
Mounting root from ufs:/dev/da2a
Root mount failed: 22

Manual root filesystem specification:

i've tried all kind of combos like ufs:/dev/da1s1a but nothing worked out.
what i still can't understand is why it's trying to mount /dev/da2 instead of /dev/da1

i would appreciate any advice!
thank you in advance

Alexandru Savescu

More information about the freebsd-questions mailing list