ping: sendto: No buffer space available

Bill Moran wmoran at
Tue Jun 17 07:09:15 PDT 2003

jaime at wrote:
> On Tue, 17 Jun 2003, Bill Moran wrote:
>>What make/model of NIC are you using?
> cerberus# ifconfig -a
>         inet netmask 0xffffff00 broadcast
>         ether 00:e0:81:21:45:8c
>         media: Ethernet autoselect (10baseT/UTP)
>         status: active


> 	The interface in question is  That interface has worked
> fine for over a year.  That driver is in use on several other systems for
> several years each.  No problems until now.

I, too, have use Intel cards with the fxp driver quite often, with no

>>The only time I've ever seen this, the only thing that solved the problem
>>was swapping the network card out for a better one.
>>That's not to say it isn't a driver problem, as the new network card used
>>a different driver as well.
> 	I think that the NIC is on the logic board.  I can try to install
> a PCI card and use that in its place to see if the problem goes away.
> Should I bother?

I would.  There are two possibilities that I would consider here:
a) The NIC has gone flaky with age
b) Newer drivers don't talk to that particular NIC as well as the old

Did you notice this starting to happen after a particular upgrade?  You
may be able to correlate this with a particular update to the driver by
looking at dates in the cvs logs.

This is hearsay, and I have no personal experience with it, but I've
seen lots of complaints across the lists about "onboard" cards that
use the fxp driver not being very good.  I've never had (nor heard of)
any problems with the PCI versions.

Another possibility is hardware ... have you added any hardware or
changed any BIOS settings?  There's the possibility of interrupt

I'm just shooting out ideas for you to work with.  Please distill
everything I've said through your own experience.  i.e. take it with
a grain of salt, as I don't _know_ what your problem is.

> 	FWIW, a reboot of the system did not help.

Never helped for me either.  You may want to check, but in my experience
the output of 'netstat -m' will also tell you that you have plenty of
network buffers available.

Bill Moran
Potential Technologies

More information about the freebsd-questions mailing list