diskless: FBSD 5.1 fails, 5.0 and 4.8 do it

Hartmann, O. ohartman at klima.physik.uni-mainz.de
Sun Jun 15 06:15:43 PDT 2003


Our setup for a cluster and a bunch of diskless terminals utilizes
a DHCP and NFS server to do the job. Each client boots via PXE
(Intel NICs) and then mounts its root filesystem via NFS. This
setup works now for a really long time but it doesn't with rcNG!!

Using the new style setup with RCNG exclusively the cient boots its
kernel and then fails working on the rc-scripts. I figured out that
the client does not recognize whether it is diskless or not. Doing
so with the old style rc.diskless scripts works perfect.

I became aware of the problem when changing the setup from old style
rc scripts towards rc_ng. After mounting root FS, the client operates
on /rootpath/etc/rc script and should then recognize it is diskless
and therefore switch to rc.d/diskless and rc.d/initdiskless. These
two special scripts should then merge conf/base/etc. conf/default/etc
and conf/IP/etc together. This worked in 4.8 and 5.0 and it still works
when using the old 4.8/5.0 rc.xxx script stuff together with the new
5.1 binaries and kernel. But nothing works with rc-ng only. No memory
disk gets created, no merging is done, no diskless tasks are performed.
The process remains in the read only root filesystem and fails.

I am sure the RCNG script does not recognize a diskless operation while
with the same kernel the old style rc-system does.

has anyone the same problem? Can anyone help? What's different with the
new RCNG system to get it working?

Thanks in advance,

O. Hartmann

ohartman at mail.physik.uni-mainz.de
Systemadministration des Institutes fuer Physik der Atmosphaere (IPA)
Johannes Gutenberg Universitaet Mainz
Becherweg 21
55099 Mainz

Tel: +496131/3924662 (Maschinenraum)
Tel: +496131/3924144 (Buero)
FAX: +496131/3923532

More information about the freebsd-questions mailing list