Make -- Illegal instruction - core dumpedI've been trying to

Jack L. Stone jackstone at
Fri Jun 13 16:43:44 PDT 2003

At 04:24 PM 6.13.2003 -0700, Joshua Oreman wrote:
>On Fri, Jun 13, 2003 at 05:52:42PM -0500 or thereabouts, Jack L. Stone
seemed to write:
>> At 06:34 PM 6.13.2003 -0400, Bill Moran wrote:
>> >Jack L. Stone wrote:
>> >> I've been trying to update, via sources, an older server (586 CPU)
>> >> running a real sparse 4.5-RELEASE, but each time I use:
>> >> # make 'target' I get the following error.
>> >> Illegal instruction - core dumped
>> >> 
>> >> It's got me stopped in my tracks. Any tips for a fix appreciated....
>> >
>> >Sounds like buggy hardware.  Does it always fail at the same place?  If
>> >it's probably bad RAM or a failing or overheating processor.  Try out some
>> >tools like memtest86 or cpuburn to try to narrow it down.
>> >
>> >-- 
>> >Bill Moran
>> Thanks for the reply, Bill. The above error message is as far as it gets.
>> #make 'target' and then the error is returned....
>Does that happen with every make command? Have you tried different Makefiles
>to see whether the problem was with `make' itself?
>In any event, here's how to get some sense out of that error.
>First, make a debugging version of the `make' executable:
># gcc -g -o /usr/bin/make_g /usr/src/usr.bin/make/*.c \
>> /usr/src/usr.bin/make/lst.lib/*.c -I/usr/src/usr.bin/make \
>Then try and reproduce the error with `make_g' instead of `make'.
>If it does the same thing, do this:
>$ gdb /usr/bin/make_g make_g.core
>[copyright msgs snipped]
>(gdb) <-- Type 'where' at this prompt and send us the output.
>(gdb) quit
>-- Josh

Josh: I didn't get a "core", but here is the whole excercise I tried
following your instructs:

make_g installworld

"<snipped here where stopped>.......osreldate.h /usr/include"
*** Signal 4

Stop in /usr/src/include.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.

root at ssl>> gdb /usr/bin/make_g make_g.core
GNU gdb 4.18 (FreeBSD)
Copyright 1998 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-unknown-freebsd"...Deprecated bfd_read
called at
line 2627 in elfstab_build_psymtabs
Deprecated bfd_read called at
line 933 in fill_symbuf

/usr/src/make_g.core: No such file or directory.
(gdb) where
No stack.
(gdb) quit

Best regards,
Jack L. Stone,

SageOne Net
jackstone at

More information about the freebsd-questions mailing list