4.8-RELEASE w/2 NICs

Daniel Bye dan at slightlystrange.org
Fri Jun 13 09:17:26 PDT 2003

Hi all,

I have just installed 4.8-RELEASE on a system using an Asus A7N266-VM mobo,
in a 2U case.

It has three PCI slots, but because of the low form factor, we need to use a
riser board from one of them, so that PCI cards can be added on the correct

The integrated NIC on the mobo is based on the RealTek 8201, which I know is
not supported under 4.8-RELEASE, but the box must have two network cards (it
is eventually going to be a VPN end-point).  Now, the only way to get two
additional NICs in the machine is to connect them both to the riser-board.
One of them, a VIA card, works fine.  The other, a NetGear FX310, doesn't
work - it is detected by the OS - dmesg shows the correct values for miibus0
and miibus1, but all I get from it is dc0: watchdog timeout.

I have checked the man page for the dc driver, and know this message is
generated when the device cannot deliver interrupts, or if there is a
problem with the network setup.  I can discount the latter - the VIA vr0
interface works fine on the same cables and network segment.

Which leaves the interrupts - this is what the BIOS shows for the two cards
in question:

Bus  Dev no.  Vendor ID  Dev ID  IRQ
1     6        1106      3106     5    <--- VIA  (vr0)
1     8        11ad      0002     5    <--- NetGear (dc0)

Unfortunately, the BIOS isn't clever enough to let me change the IRQ on a
per-device basis, only per-slot - which is no good, as the two cards are
connected to the same slot.  I have tried starting the machine with the
cards reversed, in which case the device at dev no 8 still generates
watchdog timeout messages, and I have tried both cards on their own in each
slot - when connected to the dev no 6 slot on the riser, both work.  When
connected to dev no 8 on the riser, both fail.

The riser is a plotech, which sits in slot 2, and has a ribbon connector to
a card in slot 0.  Removing the card in slot 0 and disconnecting the ribbon
makes the machine sing a very unattractive tune!  (That was a long shot
anyway, borne of increasing frustration - I told my boss I could have the
thing migrated from SuSE to FreeBSD by the end of the day.  Ho hum...)

Is this setup ever going to work?  Can I somehow set one of the cards to use
a different IRQ?  I am not a hardware expert, and have never come across
this problem before.

If not, then I guess it's back to Linux, as it's able to use the integrated
8201 ethernet controller.  At least I can use Debian, and move the rest of
the guys here away from SuSE...

Any thoughts or tips on this most welcome.



Daniel Bye

PGP Key: ftp://ftp.slightlystrange.org/pgpkey/dan.asc
PGP Key fingerprint: 3D73 AF47 D448 C5CA 88B4 0DCF 849C 1C33 3C48 2CDC
                                              ASCII ribbon campaign ( )
                                         - against HTML, vCards and  X
                                - proprietary attachments in e-mail / \

More information about the freebsd-questions mailing list