spamassassin port not reading

Toomas Aas toomas.aas at
Wed Jun 11 08:45:09 PDT 2003


I tried asking this on SpamAssassin list and didn't get it solved. Maybe it is 
something specific to the FreeBSD port of SA.

I'm running Postfix 2.07, amavisd-new-20030314.p1 and SpamAssassin 2.53, all
installed from ports. Everything works fine, except that SpamAssassin as
running via amavisd-new doesn't seem to read the changes that I make to 
/usr/local/etc/mail/spamassassin/ I just whitelisted an address,
restarted amavisd-new but the mail coming from this address is still bouncing.
I've also tried changing the scores of some tests in and the changes
don't seem to 'take'. I do restart amavisd-new each time after making changes,
and it logs the following into /var/log/maillog:

Jun 11 16:40:52 kuller amavis[43126]: SpamControl: initializing Mail::SpamAssassin
Jun 11 16:40:56 kuller amavis[43126]: SpamControl: done

Interesting thing is, when I run spamassassin from command line, I see that
my changes are honored:

# spamassassin -t < false-positive

Content analysis details:   (-94.50 points, 5 required)
HEADER_8BITS       (1.2 points)  Headers include 3 consecutive 8-bit characters
USER_IN_WHITELIST  (-100.0 points)From: address is in the user's white-list
SUBJ_FULL_OF_8BITS (4.3 points)  Subject is full of 8-bit characters

So, it's only SA running via amavisd-new that doesn't read my local changes.
I'm forced to do the changes in global config files 
/usr/local/share/spamassassin/*.cf, which is Bad Thing. Help!
Toomas Aas | toomas.aas at |
* It's always darkest right before you step on the cat.

More information about the freebsd-questions mailing list