Anyone built apache13-modssl since June 04?

Bill Moran wmoran at
Wed Jun 11 06:09:47 PDT 2003

Dirk Meyer wrote:
> Bill Moran schrieb:,
>>I'm trying to build/install the apache13-modssl port and I'm getting
>>continual failures at the same point
>>Anyone else having trouble with this.  Looks like the last commit
>>was made on the 4th, so this could be fairly recent breakage.
> nope ...  builds here on stable and current.

What version of mm are you using?  I've tried installing multiple times and
each time I get the exact same failure.  I've reinstalled mm at least 3 times,
refetched the source for mm twice and tried using pkg_add to install mm once
and nothing changes.
I've upgraded to 4.8, rebuilt world and kernel without grief, so I'm assuming
the hardware is sound. Any guess why mm won't work?

>>cc -c -I/usr/local/include -I../os/unix -I../include  -DHARD_SERVER_LIMIT=512 
>> -DDOCUMENT_LOCATION=\"/usr/local/www/data/\"  -DDEFAULT_PATH=\"/usr/local/bin
>>:/bin:/usr/bin\"  -DACCEPT_FILTER_NAME=\"httpready\" -DFD_SETSIZE=1024 -funsig
>>ned-char -DMOD_SSL=208114 -DEAPI -DEAPI_MM -DUSE_EXPAT -I../lib/expat-lite -O 
>>-pipe  -DNO_IDEA -Wl,-rpath,/usr/lib:/usr/local/lib `../apaci` alloc.c
>>alloc.c:146: syntax error before `*'
>>alloc.c:146: warning: data definition has no type or storage class
>>alloc.c: In function `free_blocks':
>>alloc.c:324: `AP_MM_LOCK_RW' undeclared (first use in this function)
> your mm looks broken. Please reinstall your mm
> $ cd /usr/ports/devel/mm && make deinstall
> $ cd /usr/ports/devel/mm && make install

Bill Moran
Potential Technologies

More information about the freebsd-questions mailing list