BTX halted when installing on a HP Proliant DL360 G3

David Landgren david at
Wed Jun 11 04:12:57 PDT 2003


I just received a new batch of servers to deploy. Among the lot I have 
3 HP Proliant DL360 G3 servers that refuse to run the installation CD. 
I think this is because HP have switched to Ultra 320 drives and I 
don't think FreeBSD has caught up with that. I have two 18Gb 15000rpm 
drives mounted in RAID-1.

The BIOS says "Proliant System BIOS - P31 (03/01/2003)".

I've tried various BIOS options, but the boot always goes like this:

Miniboot 4.1
Attempting Boot From CD-ROM
CD Loader 1.01

Building the boot loader arguments
Lookup up /BOOT/LOADER... Found
Relocating the loader and the BTX
Starting the BTX loader

BTX Loader 1.00  BTX version is 1.01
Console: internal video/keyboard
BIOS CD is cd0
BIOS drive A: is disk0

inf=0000000d err=00000000 efl=00030006
BTX halted

I.e.: it looks like it's when it hunts for hard disks.

I trawled the archives and learnt that people had similar problems on 
Compaq hardware, although with Adaptec controllers. The solution there 
was to create a DOS partition on the disk beforehand. I tried this, 
with no success.

I've tried booting from 4.8-RELEASE, 5.1-RELEASE and the 5.1 
miniloader, all with similar results. I also tried booting of an 
OpenBSD 3.3 CD. It gets a bit further, but when it comes to choosing I 
for Install, it reports that there are no hard disks available.

It seems like FreeBSD simply hasn't caught up yet. I had a look at the 
Testdrive machines offered by HP, but they're still running 4.8 on a 
DL360 G2.

If anyone has some idea as to how to proceed, I'd be really grateful. 
The only alternative would be to try and install Linux. But I've been 
unhappy with Linux performance under load in the past (and it's these 
servers I'm replacing) so it would be sad to continue in that vein.

Thanks for the clues,

More information about the freebsd-questions mailing list