Another Compaq EVO D510 "BTX halted" case

Johannes Lochmann johannes.lochmann at
Tue Jun 10 12:48:01 PDT 2003

Hi all,

the subject says it all: I got this nice quiet Compaq EVO D510 Convertible 
Mini Tower on my desk and tried to install FreeBSD 5.1-RELEASE on it so it 
would match the other machines here and got immedeately stuck while booting 
from CDROM with a "BTX halted" case.

Google found the suggestion to switch to "Max PIO" and turn of DMA:

Unfortunately this does not work for me and leads to this (5.1-RELEASE):

int=0000000d  err=00000000  efl=00030246  eip=00002c13
eax=0000203c  ebx=00000004  ecx=00002000  edx=0000246b
esi=000008d5  edi=0006088c  ebp=00001538  esp=00001502
cs=f000  ds=ee00  es=ee00    fs=0000  gs=0000 ss=ee00
cs:eip=0f 20 dd 81 e5 00 f0 0f-20 c2 0f 01 e0 a8 01 75
       08 80 e2 fe e8 53 ff eb-21 0f 20 e0 a9 30 00 75
ss:esp=8c 08 06 00 d5 08 00 00-38 15 00 00 22 15 00 00
       04 00 00 00 6b 24 00 00-04 00 00 00 3c 24 00 00
BTX halted

This is the system configuration:

Compaq EVO D510 Convertible Mini Tower
P4 2000 MHz
256 MB RAM
CDROM in the Compaq Multibay slot, recognized by the boot loader as cd0.

Tried FreeBSD versions showing this problem where:


Anybody got a hint for me? I'm really stuck here...

Thank you in advance,

Johannes Lochmann

More information about the freebsd-questions mailing list