2 filesystem problems: blst_radix_free and bad inode number

Michael A. Smith msmith at code-fu.com
Mon Jun 9 09:57:57 PDT 2003

I've got an AMD Duron-700 running FreeBSD 4.8-RC. It's got a Promise IDE 
RAID card and two identical 40GB Maxtor drives (less than six months 
old) -- mirrored. No floppy, no CD-ROM, no other IDE drives. The machine 
is a headless Samba fileserver in my office. A few days ago, it became 
unreachable by SSH (filesharing still worked).

I had to power-cycle it to get it down and plugged into a monitor and 
keyboard. It's having two problems when booting:

1) if I try to boot normally (multiuser), it panics when loading the 
root filesystem, then reboots (again and again...):

    panic: blst_radix_free: freeing free block

2) If I boot single-user, it mounts the root filesystem. When I try to 
fsck the various filesystems (/, /var, /tmp, /usr) I get this error when 
fscking /dev/ar0s1g (/usr):

    fsck: bad inode number 132352 to setinodebuf

All the other filesystems come up clean.

I don't know if the problems are related. I disassembled the array and 
booted from one of the mirrored drives alone -- same error -- then I 
reassambled the array.

Any ideas on how to solve one or both of these problems?


Michael A. Smith

More information about the freebsd-questions mailing list