new 5.1 install network problem.

Mike Gruen magruen at
Mon Dec 22 09:30:56 PST 2003

Clarence Brown wrote:
> Thanks for the Reply:
> I believe that the DNS timeout is a symptom rather than cause
> of the problem, because I'm getting an 80% packet loss when
> pinging the IP address of the DNS server. I'm running the DNS
> servers, and they are on the same LAN.
I've seen this type of response when there is a mismatch of autosensing 
network adapters. Try forcing your network card to whatever speed and 
duplex setting you prefer to run at and make sure that the switch port 
your connected to is set the same. The machine you're configuring is at 
full-duplex, but the switch may be at half duplex.

> resolv.conf is same on this machine as on other machines that
> do work.
> The LAN does have DHCP, but I assigned this FreeBSD
> machine a static IP at an unused address in a range of addresses
> that I have reserved for servers.
> in rc.conf (the ip addresses are the values I expect):
> defaultrouter="###.###.###.###"
> hostname=""
> ifconfig_xl0="inet ###.###.###.### netmask ###.###.###.###"
> in hosts, I had to add the correct domain to localhost, and add
> entries for the machine's own name, but this didn't seem to help.
> With further testing, still getting 60%-80% packet loss when trying
> to ping IP address of other machines on network from problem
> machine, but some DO get through. Other machines are getting
> similar results when trying to ping the IP address of the problem machine.
> Thanks again, Cla.
> ----- Original Message ----- 
> From: "fbsd_user" <fbsd_user at>
> To: "Clarence Brown" <clabrown at>;
> <freebsd-questions at>
> Sent: Monday, December 22, 2003 11:07 AM
> Subject: RE: new 5.1 install network problem.
>>You are correct, sure sounds like DNS time out problem.
>>Do you have hostname='' in rc.conf
>>Do you have entry in /etc/hosts file for ip address of Nic card and
>>it's FQDN  IE: ''
>>If this PC is connected to lan, does the lan use DHCP, and if so do
>>you have ifconfig_xl0="DHCP" in rc.conf?
>>Check /etc/resolv.conf to see that it has the IP address of your ISP
>>DNS severs.
>>-----Original Message-----
>>From: owner-freebsd-questions at
>>[mailto:owner-freebsd-questions at]On Behalf Of Clarence
>>Sent: Monday, December 22, 2003 10:16 AM
>>To: freebsd-questions at
>>Subject: new 5.1 install network problem.
>>Please help me troubleshoot a network problem. In the past,
>>after installing, it has all just worked, so I'm not sure exactly
>>how to best proceed. When the PC was formatted as Win98
>>the network connection worked fine, and the cabling is on
>>my work bench and works fine on other test systems, so I don't
>>suspect a hardware problem.
>>I just installed 5.1 from the CD's on to an IBM Aptiva E96.
>>It has a 3Com 3C905B-TXNM card, which seems to have
>>been correctly identified. On Boot things seem to proceed
>>normally until the Sendmail message where the boot seems to
>>stop for several minutes. (I thought I selected to not enable
>>sendmail .... )
>>Name resolution is not working and the network connection
>>seems to be timing out a lot as all network functions are
>>very sluggish. For instance, I CAN ping the IP of my
>>name server, however even though the response is less
>>than 1ms, there is about 80% packet loss.
>>nslookup can't connect to the name server, even using IP,
>>and again I suspect that it is timing out.
>>Was able to connect to my FTP server using its IP to try to
>>transfer some files, for this email, but the connection timed out
>>nd was reset when trying to cd to the "input" directory.
>>Here are what I think are the relevant lines from my messages
>>log where the card is found on boot:
>>Dec 22 09:16:27 fbsd04 kernel: xl0: <3Com 3c905B-TX Fast Etherlink
>>XL> port
>>0x7080-0x70ff mem 0x80100000-0x8010007f irq 10 at device 13.0 on
>>Dec 22 09:16:27 fbsd04 kernel: xl0: Ethernet address:
>>Dec 22 09:16:27 fbsd04 kernel: miibus0: <MII bus> on xl0
>>Dec 22 09:16:27 fbsd04 kernel: xlphy0: <3Com internal media
>>interface> on
>>Dec 22 09:16:27 fbsd04 kernel: xlphy0:  10baseT, 10baseT-FDX,
>>100baseTX-FDX, auto
>>Here is output from ifconfig with the IPs obscured, but the IP looks
>>good to
>>     options=3<RXCSUM,TXCSUM>
>>     inet ###.###.###.### netmask 0xXXXXXXXX broadcast
>>     inet6 fe80::210:5aff:fea0:ce0b%xl0 prefixlen 64 scopeid 0x1
>>     ether 00:10:5a:a0:ce:0b
>>     media: Ethernet autoselect (100baseTX <full-duplex>)
>>     status: active
>>lp0: flags=8810<POINTOPOINT,SIMPLEX,MULTICAST> mtu 1500
>>lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
>>     inet6 ::1 prefixlen 128
>>     inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3
>>     inet netmask 0xff000000
>>Any ideas/suggestions?
>>Thanks, Cla.

More information about the freebsd-questions mailing list