new 5.1 install network problem.

fbsd_user fbsd_user at
Mon Dec 22 08:07:27 PST 2003

You are correct, sure sounds like DNS time out problem.
Do you have hostname='' in rc.conf
Do you have entry in /etc/hosts file for ip address of Nic card and
it's FQDN  IE: ''
If this PC is connected to lan, does the lan use DHCP, and if so do
you have ifconfig_xl0="DHCP" in rc.conf?
Check /etc/resolv.conf to see that it has the IP address of your ISP
DNS severs.

-----Original Message-----
From: owner-freebsd-questions at
[mailto:owner-freebsd-questions at]On Behalf Of Clarence
Sent: Monday, December 22, 2003 10:16 AM
To: freebsd-questions at
Subject: new 5.1 install network problem.

Please help me troubleshoot a network problem. In the past,
after installing, it has all just worked, so I'm not sure exactly
how to best proceed. When the PC was formatted as Win98
the network connection worked fine, and the cabling is on
my work bench and works fine on other test systems, so I don't
suspect a hardware problem.

I just installed 5.1 from the CD's on to an IBM Aptiva E96.
It has a 3Com 3C905B-TXNM card, which seems to have
been correctly identified. On Boot things seem to proceed
normally until the Sendmail message where the boot seems to
stop for several minutes. (I thought I selected to not enable
sendmail .... )

Name resolution is not working and the network connection
seems to be timing out a lot as all network functions are
very sluggish. For instance, I CAN ping the IP of my
name server, however even though the response is less
than 1ms, there is about 80% packet loss.

nslookup can't connect to the name server, even using IP,
and again I suspect that it is timing out.

Was able to connect to my FTP server using its IP to try to
transfer some files, for this email, but the connection timed out
nd was reset when trying to cd to the "input" directory.

Here are what I think are the relevant lines from my messages
log where the card is found on boot:

Dec 22 09:16:27 fbsd04 kernel: xl0: <3Com 3c905B-TX Fast Etherlink
XL> port
0x7080-0x70ff mem 0x80100000-0x8010007f irq 10 at device 13.0 on
Dec 22 09:16:27 fbsd04 kernel: xl0: Ethernet address:
Dec 22 09:16:27 fbsd04 kernel: miibus0: <MII bus> on xl0
Dec 22 09:16:27 fbsd04 kernel: xlphy0: <3Com internal media
interface> on
Dec 22 09:16:27 fbsd04 kernel: xlphy0:  10baseT, 10baseT-FDX,
100baseTX-FDX, auto

Here is output from ifconfig with the IPs obscured, but the IP looks
good to

     inet ###.###.###.### netmask 0xXXXXXXXX broadcast
     inet6 fe80::210:5aff:fea0:ce0b%xl0 prefixlen 64 scopeid 0x1
     ether 00:10:5a:a0:ce:0b
     media: Ethernet autoselect (100baseTX <full-duplex>)
     status: active
lp0: flags=8810<POINTOPOINT,SIMPLEX,MULTICAST> mtu 1500
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
     inet6 ::1 prefixlen 128
     inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3
     inet netmask 0xff000000

Any ideas/suggestions?

Thanks, Cla.

freebsd-questions at mailing list
To unsubscribe, send any mail to
"freebsd-questions-unsubscribe at"

More information about the freebsd-questions mailing list