[Fwd: Portupgrade Stale Dependency Issue]

Ion-Mihai Tetcu itetcu at apropo.ro
Sat Dec 20 15:56:17 PST 2003

On Sat, 20 Dec 2003 18:32:34 -0500
Bob Perry <rperry4 at earthlink.net> wrote:

> Just ran pkgdb -F per prompt from the portversion program and got the 
> following
> two messages:
> Stale origin: 'textproc/ruby-rdoc': perhaps moved or obsoleted.
> -> The port 'textproc/ruby-rdoc' was removed on 2003-12-15 because:
>        "integrated into ruby18 and ruby16-shim-ruby18"
> -> Hint: ruby-rdoc-0.9.0 is not required by any other package
> -> Hint: checking for overwritten files...
> -> No files installed by ruby-rdoc-0.9.0 have been overwritten by
> other packages.
> Deinstall ruby-rdoc-0.9.0 ? [no]
> Appears as though I'm being told that ruby-rdoc-0.9.0 can be removed, 
> yet the
> default selection re deinstall is "no".  Am I missing something?

As the hint says, you can deintsall it. After you're done with pkgdf -F
do a portupgrade -r on ruby18 or ruby16-shim-ruby18, which ever you
> Second:
> Stale dependency: gnome2-2.4.1 -> openldap-client-2.1.23 
> (net/openldap21-client):
> openldap-client-2.0.27 (score:76%) ? ([y]es/[n]o/[a]ll) [no]

It seems that you had down-graded your open-ldap. You now have installed
openladap 2.0.27 on you system, but when you've installed gmnome you had
2.1.13; you can either choose:
a) yes (or all) and doing so will "point" gnome (or all) "to depend" on
openldap-client-2.0.27 or 
b) no, terminate pkgbd and do a portupgrade on openldap-client to bring
it back to 2.1.xx

Choose what you need (if you have something that requires 2.0 do a if
not do b.)

> I click the default selection "no" and I'm prompted to input a new 
> dependency.
> Assuming that I need to install openldap-client-2.1.23, I review the
> net/openldap21-client port directory and I only find a Makefile.

And ? That make file sets CLIENT_ONLY=yes and includes the
../openldap21-server's Makefile so all is OK. Looking at the places
where CLINET_ONLY appears in the Make file tells that You can define to
have or not the docs installed and to have WITH_SASL with (Cyrus) SASL2

> If someone can explain what the program is asking, I may be in a
> better position to respond appropriately.

Unregistered ;) FreeBSD user

More information about the freebsd-questions mailing list