Stupid cvsup questions

Garance A Drosihn drosih at
Mon Dec 15 18:44:12 PST 2003

At 11:41 PM +0200 12/15/03, Ion-Mihai Tetcu wrote:
>I have 2 identical (copy/paste) ports-supfiles on two machines:
>it# grep -v '#' /etc/ports-supfile
>*default base=/usr
>*default prefix=/usr
>*default release=cvs tag=.
>*default delete use-rel-suffix
>*default compress

>I run it like:
># cvsup -g /etc/ports-supfile on both machines.
>The stupid question:
>why on the second I have the `,v' suffix ?
>Is there an env variable or something ?

I don't think so.  Did you try copying the file from one
machine to the other, and doing a direct diff?  It looks
like the 'tag=.' is being ignored for some reason.

I suspect you have tried that, but it's hard to imagine
why the two machines would be different.  I'd also note
that your grep command shouldn't ignore lines that have
a '#' that is anywhere in the line.  Only ignore lines
where there is nothing interesting before the '#'.  Eg:

    grep -v '^ *#'

I don't know what else to suggest.  From what you describe
in your message, both hosts should be getting the same set
of files.

Garance Alistair Drosehn            =   gad at
Senior Systems Programmer           or  gad at
Rensselaer Polytechnic Institute    or  drosih at

More information about the freebsd-questions mailing list