Set boot loader to boot off CD manually

Daniel Goepp freebsd at
Tue Dec 9 08:12:13 PST 2003

Hi all,

I was banging my head against the wall too long yesterday, so I have
broken down, and have to ask.  Any help on this matter is greatly

Here is what I'm trying to do.  I have two computers, both running 4.8,
clean, minimal installs.  They have two serial cables connected to each
other to act as serial consoles, and -Dh has been added to /boot.config,
along with ttys having been updated.  The console bit works great.  What I
want to be able to do, is completely rebuild one of the machines remotely.
 So I log into one, serial over to the other, and reboot it.  Then, when
the loader comes up, I stop it, and break to the "ok" prompt.  I unload
the kernel that was starting to load, and at this point, want to boot off
CD, to rebuild the system, as though I had gone into the BIOS, and set the
CD as the first boot device.  However, I don't have remote access to the
BIOS, so I can't do this.

Here is some information about the systems, and what I have tried so far:

They are identical computers, that I built myself, very default machines. 
IDE everything.

atapci0: <SiS 5591 ATA100 controller> port 0xff00-0xff0f at device 2.5 on
ata0: at 0x1f0 irq 14 on atapci0
ata1: at 0x170 irq 15 on atapci0

ata1-slave: ATAPI identify retries exceeded
ad0: 38166MB <ST340016A> [77545/16/63] at ata0-master UDMA100
acd0: CDROM <FX54++W> at ata1-master PIO4

I have tried all combinations of load that I can think of.  And I have
tried setting loaddev and root_disk_unit to all sorts of things.  Here is
the output from a lsdev:

cd @ 0xff5c
disk @ 0xef68
    disk0:   BIOS drive A:
    disk1:   BIOS drive C:
        disk1s1a: FFS
        disk1s1b: swap
        disk1s1e: FFS
        disk1s1f: FFS
        disk1s1g: FFS
pxe @ 0xd6d8

I have also tried just doing an ls on the device, by setting currdev to
all sorts of cd9660:cd, just 'cd' and the BIOS physical
addresses in the form X:acd(Y,Z) [0-4]:acd([0-4],[a-c])

No joy.

I have also tried booting with the -C option, and here is the tail end of
that attempt:

acd0: CDROM <FX54++W> at ata1-master PIO4
Mounting root from cd9660:cd0a
no such device 'cd'
setrootbyname failed
iso_mountroot: can't find rootvp
Root mount failed: 6
Mounting root from cd9660:acd0a
cd9660: RockRidge Extension
init: not found in path
panic: no init

No joy.

I'm trying to think what other information might be useful.  As I see it,
the problem is, that once a version of FreeBSD has been installed, and the
loader loads off the HD, it doesn't want to have anything to do with the
CD any more...

I realize I have other options, like PXE or FTP, or having an "install
partition", to hold an install of BSD, just to install to the other
partition.  I really don't want to go down these roads right now, since I
want to be able to have someone pop in a new CD, to switch around versions
of BSD running on these boxes.

Help anyone!?



More information about the freebsd-questions mailing list