Named errors - running BIND in sandbox

Ceri Davies ceri at
Mon Dec 1 10:44:52 PST 2003

On Sat, Nov 29, 2003 at 04:18:13PM +0000, Stacey Roberts wrote:
> Hello,
> I know that I've asked this in the past, but after a
> fresh reinstall of the machine on my local network that provided
> (amongst other services) DNS to all other machines (FreeBSD, Solaris,
> WIn2K & WinXP Pro), I find that I am not having much success setting up
> BIND in a sandbox.
> The box is running FreeBSD-4.9Stable (after initially installing
> 4.8-Rel) after cvsup of sources.
> Basically, the errors I get on start up is here:

> /etc/namedb/etc # tail /var/log/messages
> Nov 29 15:42:39 Demon named[226]: 'masters' statement present for master zone ''
> Nov 29 15:42:39 Demon named[226]: zone '' did not validate, skipping

> zone "" {
>         type master;
>         file "master/";
>         allow-transfer {; };
>         masters {
>       ;
>         };
> };

You have declared the zone as type master, but also included a masters
statement.  If this machine is the master, then remove the masters
statement, otherwise, declare it as type slave.

> Nov 29 15:42:39 Demon named[226]: bind(dfd=20, [].53): Address already in use
> Nov 29 15:42:39 Demon named[226]: deleting interface [].53
> Nov 29 15:42:39 Demon named[226]: bind(dfd=20, [].53): Address already in use
> Nov 29 15:42:39 Demon named[226]: deleting interface [].53

named was already running when you tried starting it this time.

> Nov 29 15:42:39 Demon named[234]: can't exec /bin/named-xfer: No such file or directory

You didn't show the contents of the bin directory below, but I assume
it's empty; copy /usr/libexec/named-xfer in there (make sure it's
statically linked, which is the default in 4.9-RELEASE).

> Nov 29 15:43:47 Demon named-xfer[240]: [] not authoritative for, SOA query got rcode 0, aa 0, ancount 0, aucount 13

Now, I'm taking a big guess here.
You didn't have in the named.conf before you
started named this time, but now you do.  Since you declared it as a
slave zone (which looks to be incorrect), named tried to transfer it
from itself, which it couldn't do as it wasn't loaded before.

> What I had prior to installing, I would get ""
> returned as the Default Server, not localhost as above.

It is now listed second in your resolv.conf.

> Secondly, the address is the real IP address of Demon (I
> have a block of 8) that is translated to, the internal IP
> address of Demon. So I'd have hoped that trying to set server to Demon,
> would have resulted in "Address:" instead of the machine's
> real IP address.

Since the zone didn't load, this server wasn't
authoritative for that zone, and so went to the forwarder you have
listed and asked there; that server then gave the public IP.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url :

More information about the freebsd-questions mailing list