need advice: core dumps during buildworld

Redmond Militante r-militante at
Sun Aug 31 17:04:53 PDT 2003

hi all

i am having trouble trying to cvsup a 5_1-RELEASE machine

i'm at the 'cd /usr/src/ make buildworld' stage. i can't run 'make buildworld'
successfully on this machine. i'm able to on my other 5_1-RELEASE machine
(although it's different hardware...). the buildworld seems to fail at
different points randomly. for ex., the most current kernel core dump/error i
get when trying to complete this operation is

Illegal instruction(core dumped)
****Error code 132

stop in /usr/src/usr.bin/objformat
***Error code 1
stop in /usr/src/usr.bin.
***Error code 1...

Aug 28 12:30:39 host kernel : pid 61508 (make), uid 0: exited on signal 4 (core

my hardware:

dell optiplex gx250 p4 2.4 ghz
500 mhz ram

FreeBSD 5.1-RELEASE-p2 #1

-i was advised that problems like these most often are a result of bad ram. i ran memtest on this machine, it found no errors. i ran dell hardware diagnostics on this machine, also found no errors. i pull each stick of ram separately - the buildworld problem reappeared no matter which stick of ram is in the machine, or which ram slot on the motherboard it's plugged into.

one thing to note is that, before i wiped this machine and reinstalled 5_1, this machine cvsupped flawlessly for a year as a 4x-RELEASE machine, with the same ram.

i'm hoping that there's something else i can try before wiping/reinstalling 5_1. i'm not even sure if reinstalling will fix the problem. 

if anyone has any words of advice, i'd appreciate it

FreeBSD 5.1-RELEASE-p2 FreeBSD 5.1-RELEASE-p2 #0: Thu Aug 28 12:42:04 CDT 2003
 6:55PM  up 3 days,  5:53, 3 users, load averages: 0.81, 0.54, 0.33
Individualists unite!
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url :

More information about the freebsd-questions mailing list